[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Fwd: Re: Xen 4.3 / 4.4 - concurrent APIs, VGA Passthru

  • To: Gordan Bobic <gordan@xxxxxxxxxx>
  • From: Georg Bege <therion@xxxxxxxxxxxx>
  • Date: Mon, 18 Aug 2014 17:26:24 +0200
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Mon, 18 Aug 2014 15:28:07 +0000
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=ninth-art.de; h=message-id :date:from:reply-to:mime-version:to:cc:subject:references :in-reply-to:content-type:content-transfer-encoding; q=dns; s= mail2013; b=Pdv8ccX9uSuA6z0MuMspyJF3j9z4uZTi2x0YLxHqv6FwiYIuA96t MToU8hsz0eQCzogpywZdwAKAaCoLMSyjKogoodM6kOe4d4jsWbonK6dswqQ7Yjh3 40jPs9CQtVCEN2dMq0dlsfvexFSwYQF2sYAsiZFDHNLsKoOKVMjRYtk=
  • List-id: Xen developer discussion <xen-devel.lists.xen.org>


I simply wanted to tell my tale about the outcome of my experiments,
I was occupied with certain other things (including exchanging some
For now I run an Vista x64 and it works pretty well, I never got the
gplpv drivers running on
acceptable levels (they are still quite slow) so I decided to pass
onboard controller, sound and usb3.
This decission seemed to be a wise one and everything works great as
expected, the problem with gplpv
well it might also be a result of my volume scheme since I only run ZFS
- now an raidz1 (on enterprise disks though).
I also replaced the nvidia drivers from 331.65 to 337.88 - this revision
gave me a lot more performance but I can remember I had this issue on
native Windows too.

So after a lot of testing, pain, time consuming days (and nights) its
really working great - not perfect maybe.
My next goal is to dedicate an SSD for that system volume, maybe try
Win7 again as well -
also I'd like to get an GTX690 and hardmod it so I get a lot more speed...


Am 04.08.2014 10:18, schrieb Gordan Bobic:
> On 08/03/2014 11:09 AM, Georg Bege wrote:
>> Am 03.08.2014 11:49, schrieb Gordan Bobic:
>>> On 08/02/2014 11:49 AM, Georg Bege wrote:
>>>> Hello again
>>>> Well so far I can now tell, I tested it on WinXP x64 quite a lot
>>>> - most things are working.
>>>> Including AAA games like Witcher 2, I didnt try a very memory
>>>> consuming
>>>> game yet.
>>>> But I dont really think that I have the same bug you are refering to -
>>>> in WinXP x64 the /PATCHTPR boot flag did help greatly, it really
>>>> boosted
>>>> the performance to near native.
>>> What does this flag do? Googling for it found no results.
>> See:
>> http://lists.xenproject.org/archives/html/xen-users/2013-09/msg00254.html
>> But now I came to the conclusion that I dont have the same issue with
>> Win7 at all (see last email).
> This reminds me - I had issues with the latest GPLPV drivers on
> Windows 7. The installer would just sit there and never complete,
> which also, IIRC, left the VM OS in a dodgy state. So I nstalled the
> same version (version number, not package, obviously) I've been
> running on XP64 for ages (11.0.372) and that worked fine.
>>>> I dont think I encountered any memory usage, used like applications
>>>> consuming the first 4GB of the DomU.
>>> I am inclined to agree, you aren't hitting the same problem.
>>>> Im trying to figure what to do for Windows 7, its working good too -
>>>> even with VGA Passthrough,
>>>> but its almost always consuming 33%-80% CPU usage for no reason...
>>> Can you check from within the domU which process is eating CPU? Or are
>>> you saying that with Windows 7 inside your domU task manager is
>>> showing 0% CPU usage but xentop is showing 33-80% CPU usage?
>> I cant check, as states in the last email it must be about interrupts or
>> power saving states - it only happens when I pass in the GFX.
>> Without this the CPU is just idling on 0% inside the DomU.
> Funnily enough, I'm seeing something similar in dom0 when I use a
> GT630 card, but not when I'm using an 8800GT or Q2K. With the GT630,
> Xorg locks up immediately, eating 100% of CPU with ksoftirqd eating
> another 100% of CPU. X process is unkillable so the only way to
> recover is to reboot the machine. The same GT630 runs fine in another
> machine so I'm reasonably sure that's not the problem. So it _could_
> be a similar obscure bug in the Nvidia driver.
> Have you tried 331.93? That's the driver I'm using.
> Gordan

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.