[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Fwd: Re: Xen 4.3 / 4.4 - concurrent APIs, VGA Passthru

On 08/03/2014 11:09 AM, Georg Bege wrote:

Am 03.08.2014 11:49, schrieb Gordan Bobic:
On 08/02/2014 11:49 AM, Georg Bege wrote:
Hello again

Well so far I can now tell, I tested it on WinXP x64 quite a lot
- most things are working.
Including AAA games like Witcher 2, I didnt try a very memory consuming
game yet.
But I dont really think that I have the same bug you are refering to -
in WinXP x64 the /PATCHTPR boot flag did help greatly, it really boosted
the performance to near native.

What does this flag do? Googling for it found no results.

But now I came to the conclusion that I dont have the same issue with
Win7 at all (see last email).

This reminds me - I had issues with the latest GPLPV drivers on Windows 7. The installer would just sit there and never complete, which also, IIRC, left the VM OS in a dodgy state. So I nstalled the same version (version number, not package, obviously) I've been running on XP64 for ages (11.0.372) and that worked fine.

I dont think I encountered any memory usage, used like applications
consuming the first 4GB of the DomU.

I am inclined to agree, you aren't hitting the same problem.

Im trying to figure what to do for Windows 7, its working good too -
even with VGA Passthrough,
but its almost always consuming 33%-80% CPU usage for no reason...

Can you check from within the domU which process is eating CPU? Or are
you saying that with Windows 7 inside your domU task manager is
showing 0% CPU usage but xentop is showing 33-80% CPU usage?
I cant check, as states in the last email it must be about interrupts or
power saving states - it only happens when I pass in the GFX.
Without this the CPU is just idling on 0% inside the DomU.

Funnily enough, I'm seeing something similar in dom0 when I use a GT630 card, but not when I'm using an 8800GT or Q2K. With the GT630, Xorg locks up immediately, eating 100% of CPU with ksoftirqd eating another 100% of CPU. X process is unkillable so the only way to recover is to reboot the machine. The same GT630 runs fine in another machine so I'm reasonably sure that's not the problem. So it _could_ be a similar obscure bug in the Nvidia driver.

Have you tried 331.93? That's the driver I'm using.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.