[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Resume not working on 2nd gen Core i5

On 24.02.2012 06:54, Konrad Rzeszutek Wilk wrote:
>>>>>>> Does anybody have a similar problem on 2nd Gen Core i5? Any advises how
>>>>>>> to approach debugging it?
> .. snip..
>> (the same hardware)
>> On xenlinux kernel after resume there is screen content from before
>> suspend, power led light constantly (as it should), but system is
>> irresponsible (no capslock led, no reaction to sysrq, network etc).
>> On 3.x with your patches system goes into S3, but on resume is even worse - 
>> no
>> screen content at all (and no backlight) and also irresponsible, power led
>> still blinking. As 3.x tried:
>>  - your devel/acpi-s3.v7 branch directly
>>  - 3.2.7 merged with devel/acpi-s3.v7
>>  - 3.3-rc4 with devel/acpi-s3.v7
> OK. That is weird - it worked for me last time. One thing at at time then -
> try doing this from text-mode, so no graphic mode involved. For that you might
> need to disable your i915 driver altogether. Then just run 'pm-suspend' and
> see where it stops.
> The next part is... Wait a minute, this reminds me of something I encountered
> with a SandyBrige i2100 - the suspend would work, but resume would get stuck.
> The issue was with the hypervisor and if I had the acpi-cpufreq drivers loaded
> it resumed just fine. If I didn't - so hypervisor had no idea about C states 
> or
> P states, it would be stuck in the default_idle and never come back.
> So you might want for fun try also using the stable/processor-passthru.v5 and

Looks much better. At least for few suspend/resume it works. Thanks!
And: when is it planned to upstream above patches (acpi-s3 and

Best Regards / Pozdrawiam,
Marek Marczykowski
Invisible Things Lab

Attachment: signature.asc
Description: OpenPGP digital signature

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.