[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Resume not working on 2nd gen Core i5

On 23.02.2012 19:03, Konrad Rzeszutek Wilk wrote:
> On Thu, Feb 23, 2012 at 06:39:29PM +0100, Joanna Rutkowska wrote:
>> On 02/23/12 18:31, Konrad Rzeszutek Wilk wrote:
>>> On Thu, Feb 23, 2012 at 09:18:27AM -0500, Konrad Rzeszutek Wilk wrote:
>>>> On Thu, Feb 23, 2012 at 10:13:56AM +0100, Joanna Rutkowska wrote:
>>>>> Hello,
>>>>> I've been trying to resolve the issue of my T420s (Core i5 2540M, Intel
>>>>> integrated GPU) freezing at resume from S3 sleep... It seems like a
>>>>> Xen-related problems, as a similar kernel to what we use in Dom0
>>>>> (2.6.38+xenlinux), when run on baremetal shows no signs of problems at
>>>>> suspend/resume. Also I cannot find any problems reported on the internet
>>>>> with people having problems here.
>>>>> Unfortunately the only COM port on ExpressCard I have, presents itself
>>>>> as a USB device, and so I cannot really debug this issue via console.
>>>>> The /var/log/pm-suspend also doesn't reveal anything useful (after I
>>>>> reboot, that is).
>>>>> Does anybody have a similar problem on 2nd Gen Core i5? Any advises how
>>>>> to approach debugging it?
>>>>> I'm running Xen 4.1.1 with some minor patches, and 2.6.38 with xenlinux
>>>>> patches, and the i915 for the graphics. (Unfortunately I cannot just
>>>>> boot the same Dom0 kernel without Xen, as the GRUB complains about
>>>>> executable being unrecognized -- probably some problem with wrong
>>>>> compression algo).
>>>>> I also tried 3.2.5 pvops kernel for Dom0 (essentially a vanilla kernel)
>>>>> -- in this case it's even worse, as the system hangs at suspend and
>>>>> never enters S3 :/
>>>> Right. You need some patches for that in 
>>>> git://git.kernel.org/pub/scm/linux/kernel/git/konrad/xen.git 
>>>> devel/acpi-s3.v7
>>>> to make that work.
>>> What I meant to say - please try it out with those patches. It might that 
>>> you
>>> are hitting on one of the Intel bugs of the video adapter that I think
>>> are mostly fixed in the upstream kernel.
>> So, you're saying those (presumed) bugs a fixed only in the pvops, and
>> not in xenlinux?
> I am saying that they are fixed in 3.x kernels.

(the same hardware)
On xenlinux kernel after resume there is screen content from before
suspend, power led light constantly (as it should), but system is
irresponsible (no capslock led, no reaction to sysrq, network etc).
On 3.x with your patches system goes into S3, but on resume is even worse - no
screen content at all (and no backlight) and also irresponsible, power led
still blinking. As 3.x tried:
 - your devel/acpi-s3.v7 branch directly
 - 3.2.7 merged with devel/acpi-s3.v7
 - 3.3-rc4 with devel/acpi-s3.v7
 - your devel/acpi-s3.v8 branch directly
The same result on all above.

How can I debug this issue?

Best Regards / Pozdrawiam,
Marek Marczykowski
Invisible Things Lab

Attachment: signature.asc
Description: OpenPGP digital signature

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.