[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [DEBUGGING Xen 4.4.1/Qxl/Debian unstable] QXL drivers don't want to install

Il 31/12/2014 02:26, Goonie Windy ha scritto:
Ok Fabio, thanks to your configure, some bits of hacking the install part and lots of advises/support/encouragements ;) from Mark Pryor I ended up
Âinstalling 4.5RC4 with QXL support on Deb8 unstable.

So now what do you want me to test fabio?
I have win7 x64 / win 2k8R2 vms in test mode ready to install drvers.

the numerous troubles I went through are related in the IRCcopy attached.
I actually couldn't build rombios and used seabios provided by the system -like you-
I should try to compile/find latest qxl now.

rombios is used only by qemu traditional that is very old, without spice support and hvm domUs have lower performance with it.
qxl drivers in latest spice guest tools are signed and not require windows testsigning mode, same for james haper xen gplpv.
If you want test new winpv drivers instead you need it.

For me qxl is working good on w7 domUs except after save/restore when "freeze" 2-3 minutes on screen resolution change and I not found the exact problem for now.
I also not found how to have qxl working in linux domUs, on latest test xorg crash on start with qxl driver installed.
Probably other changes are needed in hvmloader and/or xen hypervisor and/or qxl driver.
Any help testing it is appreciated.

See you in 2K15.

greg B

2014-12-29 14:49 GMT+01:00 Fabio Fantoni <fabio.fantoni@xxxxxxx>:
Il 29/12/2014 14:13, Goonie Windy ha scritto:
ok, I'm trying to patch the files with yours,

I need to do it manually right?

git apply is not working here.

If the patch need a "refresh" the conflict should be solved manually.
Taking the patch updated from here probably it can be applied to latest 4.5-rc:



2014-12-29 13:46 GMT+01:00 Goonie Windy <monsieur.goonie@xxxxxxxxx>:
There is an error in pageqs describing how to compile from sources as in 4.5
cat .config

is in fact in .INSTALL

If also you use debian you can use make debball that is better for install/remove easy and fast test build.

And for example I use this configure options with xen 4.5:
./configure --prefix=/usr --disable-blktap1 --disable-qemu-traditional --disable-rombios --with-system-seabios=/usr/share/seabios/bios-256k.bin --with-extra-qemuu-configure-args="--enable-spice --enable-usb-redir" --disable-blktap2
I use wheezy building updated packages from sid: seabios 1.7.5-1, spice 0.12.5-1, spice-protocol 0.12.7-1 and usbredir 0.7-1.
If you use jessie instead you have all packages updated.

About python I'm using this workaround (before execute configure) even if probably is not the best:
-PYTHON_PREFIX_ARG ?= --prefix="$(PREFIX)"

2014-12-29 1:20 GMT+01:00 Goonie Windy <monsieur.goonie@xxxxxxxxx>:
well figured out it is because you have to "enforce" locale:Â export LC_ALL=en_US.utf-8 if keyboard mapping is else

2014-12-28 21:19 GMT+01:00 Goonie Windy <monsieur.goonie@xxxxxxxxx>:
Trying to compile xen 4.5RC4 in order to test your patch I end up with these errors compiling the Seabios directories,

any idea?

 Compiling to assembler out/src/asm-offsets.s
 Generating offset file out/asm-offsets.h
 Compiling (16bit) out/romlayout.o
 Building ld scripts
Version: rel-1.7.5-0-ge51488c-20141228_210340-E766
Traceback (most recent call last):
 File "./scripts/layoutrom.py", line 709, in <module>
ÂÂÂ main()
 File "./scripts/layoutrom.py", line 671, in main
ÂÂÂ info16 = parseObjDump(infile16, '16')
 File "./scripts/layoutrom.py", line 586, in parseObjDump
ÂÂÂ relocsection = sectionmap[sectionname]
KeyError: '.text.asm./home/goon/xen/tools/firmware/seabios-dir-remote/src/fw/smp.c.79'
Makefile:155: recipe for target 'out/romlayout16.lds' failed
make[6]: *** [out/romlayout16.lds] Error 1
make[6]: Leaving directory '/home/goon/xen/tools/firmware/seabios-dir-remote'
/home/goon/xen/tools/firmware/../../tools/Rules.mk:116: recipe for target 'subdir-all-seabios-dir' failed

2014-12-27 17:35 GMT+01:00 Goonie Windy <monsieur.goonie@xxxxxxxxx>:
Hello Fabio,

Sure thing I will help debug the win7 and the win8 versions.
Where to start?

I'll try to see if I can patch with patch from https://github.com/Fantu/Xen/commit/fadecf8d6ee0e8c7e421fafba67aa11879e8b8fe and if not will post result.

best regards,

greg Bahde

2014-12-27 15:10 GMT+01:00 Fabio Fantoni <fabio.fantoni@xxxxxxx>:

Il 27/12/2014 02:15, Goonie Windy ha scritto:
I tried to install Qxl drivers under win7/win 2k8/win8.1ÂÂÂÂÂÂÂÂ allÂÂÂÂÂÂ x64 versions, without any luck.

admin message is as follow:
Driver Management concluded the process to install driver FileRepository\qxl.inf_amd64_
neutral_f0c429882d5c81ed\qxl.inf for Device Instance ID PCI\VEN_1013&DEV_00B8&SUBSYS_11001AF4&REV_00\3&267A616A&1&28 with the following status: 0xe000022d.


can it be installed on my xen stack?

Yes but probably require a small refresh, I always posted the patch based on updated xen-unstable.

Here qxl patch refreshed for xen 4.5 if needed:

Here the latest spice guest tools for windows with qxl driver included:

Windows >=8 and similar require a new qxl drivers, there are a beta build but latest tried some months ago have serious bug and I not found recent build full working on windows 8.

On xen windows 7 domUs qxl works good except a problem after save/restore and on linux domUs is not working, for now I not found exactly cause and solution.
On mailing list up to 2 years ago you can find many my mails about.
Any help to test it is appreciated.

Sorry for my bad english.

Also, can I get invited at xendevel irc ?


Xen-devel mailing list

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.