[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [DEBUGGING Xen 4.4.1/Qxl/Debian unstable] QXL drivers don't want to install

There is an error in pageqs describing how to compile from sources as in 4.5
cat .config

is in fact in .INSTALL

2014-12-29 1:20 GMT+01:00 Goonie Windy <monsieur.goonie@xxxxxxxxx>:
well figured out it is because you have to "enforce" locale:Â export LC_ALL=en_US.utf-8 if keyboard mapping is else

2014-12-28 21:19 GMT+01:00 Goonie Windy <monsieur.goonie@xxxxxxxxx>:
Trying to compile xen 4.5RC4 in order to test your patch I end up with these errors compiling the Seabios directories,

any idea?

 Compiling to assembler out/src/asm-offsets.s
 Generating offset file out/asm-offsets.h
 Compiling (16bit) out/romlayout.o
 Building ld scripts
Version: rel-1.7.5-0-ge51488c-20141228_210340-E766
Traceback (most recent call last):
 File "./scripts/layoutrom.py", line 709, in <module>
ÂÂÂ main()
 File "./scripts/layoutrom.py", line 671, in main
ÂÂÂ info16 = parseObjDump(infile16, '16')
 File "./scripts/layoutrom.py", line 586, in parseObjDump
ÂÂÂ relocsection = sectionmap[sectionname]
KeyError: '.text.asm./home/goon/xen/tools/firmware/seabios-dir-remote/src/fw/smp.c.79'
Makefile:155: recipe for target 'out/romlayout16.lds' failed
make[6]: *** [out/romlayout16.lds] Error 1
make[6]: Leaving directory '/home/goon/xen/tools/firmware/seabios-dir-remote'
/home/goon/xen/tools/firmware/../../tools/Rules.mk:116: recipe for target 'subdir-all-seabios-dir' failed

2014-12-27 17:35 GMT+01:00 Goonie Windy <monsieur.goonie@xxxxxxxxx>:
Hello Fabio,

Sure thing I will help debug the win7 and the win8 versions.
Where to start?

I'll try to see if I can patch with patch from https://github.com/Fantu/Xen/commit/fadecf8d6ee0e8c7e421fafba67aa11879e8b8fe and if not will post result.

best regards,

greg Bahde

2014-12-27 15:10 GMT+01:00 Fabio Fantoni <fabio.fantoni@xxxxxxx>:

Il 27/12/2014 02:15, Goonie Windy ha scritto:
I tried to install Qxl drivers under win7/win 2k8/win8.1ÂÂÂÂÂÂÂÂ allÂÂÂÂÂÂ x64 versions, without any luck.

admin message is as follow:
Driver Management concluded the process to install driver FileRepository\qxl.inf_amd64_
neutral_f0c429882d5c81ed\qxl.inf for Device Instance ID PCI\VEN_1013&DEV_00B8&SUBSYS_11001AF4&REV_00\3&267A616A&1&28 with the following status: 0xe000022d.


can it be installed on my xen stack?

Yes but probably require a small refresh, I always posted the patch based on updated xen-unstable.

Here qxl patch refreshed for xen 4.5 if needed:

Here the latest spice guest tools for windows with qxl driver included:

Windows >=8 and similar require a new qxl drivers, there are a beta build but latest tried some months ago have serious bug and I not found recent build full working on windows 8.

On xen windows 7 domUs qxl works good except a problem after save/restore and on linux domUs is not working, for now I not found exactly cause and solution.
On mailing list up to 2 years ago you can find many my mails about.
Any help to test it is appreciated.

Sorry for my bad english.

Also, can I get invited at xendevel irc ?


Xen-devel mailing list

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.