[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v7 07/10] xen/common: move the memory_mapping DOMCTL hypercall to common code

On 05/07/2014 01:09 PM, Ian Campbell wrote:
> On Tue, 2014-05-06 at 09:40 +0100, Jan Beulich wrote:
>>>>> On 05.05.14 at 17:54, <avanzini.arianna@xxxxxxxxx> wrote:
>>>     v7:
>>>         - Change the name of tmp_rc to rc. Also, do not uselessly 
>>> initialize it.
>>>         - ifdef out the invocation of memory_type_changed() to be called 
>>> only
>>>           if the architecture is x86 instead of adding an useless empty stub
>>>           for ARM.
>> Was this requested by one of the ARM maintainers?
> I don't think it was me.
>> Do memory types not exist at all on ARM?
> This is types in "MTRR" sense rather than p2m type sense I think? These
> are part of the PT mappings, so I would expect something like this to
> probably be needed for any IOMMU stuff at some point.
>>  I would have expected the function to be
>> empty only until someone would get to implement it properly...
> Me too.

Yes, in the previous version I had defined an empty stub for a
memory_type_changed() function for ARM. While trying to move its prototype to a
common header according to Jan Beulich's suggestion, however, I have noticed
that the invocation of that same function, performed from the common code
handling the iomem_permission domctl, is ifdef'd out to be compiled only on an
x86 machine. I therefore thought to do the same for the memory_mapping domctl.

Do you prefer that an empty stub is added? If so, would you like also the
handling of memory_type_changed() in iomem_permission to be modified in this

>>  Other
>> architectures (ia64 at least, since that's the one I know next best after
>> x86) would surely have needed this too.
>> Jan

 * Arianna Avanzini
 * avanzini.arianna@xxxxxxxxx
 * 73628@xxxxxxxxxxxxxxxxxxx

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.