[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v7 07/10] xen/common: move the memory_mapping DOMCTL hypercall to common code

>>> On 05.05.14 at 17:54, <avanzini.arianna@xxxxxxxxx> wrote:
>     v7:
>         - Change the name of tmp_rc to rc. Also, do not uselessly initialize 
> it.
>         - ifdef out the invocation of memory_type_changed() to be called only
>           if the architecture is x86 instead of adding an useless empty stub
>           for ARM.

Was this requested by one of the ARM maintainers? Do memory types
not exist at all on ARM? I would have expected the function to be
empty only until someone would get to implement it properly... Other
architectures (ia64 at least, since that's the one I know next best after
x86) would surely have needed this too.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.