[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Question about running Xen 4.4 on Arndale board

Hello Julien,Â

I'm Hyonyoung Choi, working on Xen into Arndale-Octa board with Meng.

I tried to recompiled xen with CONFIG_EARLY_PRINTK=exynos5250 as your advice.

The command line is like this:

make distclean
export CONFIG_EARLY_PRINTK=exynos5250
make dist-xen XEN_TARGET_ARCH=arm32

The result is nothing happened at all.
No additional message is printed.

Here is the boot log.

U-Boot 2012.07 (Feb 15 2014 - 17:29:55) for ARNDALE OCTA

CPU: Exynos5420 Rev2.0 [Samsung SOC on SMP Platform Base on ARM CortexA15]
APLL = 800MHz, KPLL = 600MHz
MPLL = 532MHz, BPLL = 800MHz

WARNING: Caches not enabled

TrustZone Enabled BSP
BL1 version:

Checking Boot Mode ... SDMMC
MMC: Â S5P_MSHC2: 0, S5P_MSHC0: 1
MMC Device 0: 3.7 GiB
MMC Device 1: 3.6 GiB
MMC Device 2: MMC Device 2 not found
there are pending interrupts 0x00000001
*** Warning - bad CRC, using default environment

In: Â Âserial
Out: Â serial
Err: Â serial
Net: Â No ethernet found.
(Re)start USB...
USB: Â Register 1313 NbrPorts 3
scanning bus for devices... The request port(2) is not configured
The request port(2) is not configured
3 USB Device(s) found
   Âscanning bus for storage devices... 0 Storage Device(s) found
   Âscanning usb for ethernet devices... 1 Ethernet Device(s) found
Hit any key to stop autoboot: Â0
reading boot.scr

531 bytes read
Running bootscript from mmc0:2 ...
## Executing script at 22000000
reading /zImage

4801504 bytes read
reading /xen-uImage

557904 bytes read
## Booting kernel from Legacy Image at 50000000 ...
 ÂImage Name: Â
 ÂImage Type:  ARM Linux Kernel Image (uncompressed)
 ÂData Size:  Â557840 Bytes = 544.8 KiB
 ÂLoad Address: 80200000
 ÂEntry Point: Â80200000
 ÂVerifying Checksum ... OK
 ÂLoading Kernel Image ... OK
Starting kernel ...


About SD-card image,
I re-used the prebuilt image for arndale-octa at http://releases.linaro.org/14.01/ubuntu/arndale-octa

After writing the image to the SD card, I replace newly compiled kernel image and xen image.

kernel image I used:
export ARCH=arm
export CROSS_COMPILE=arm-linux-gnueabi-
scripts/kconfig/merge_config.sh linaro/configs/linaro-base.conf linaro/configs/distribution.conf \
linaro/configs/kvm-host.conf linaro/configs/xen.conf linaro/configs/arndale_octa.conf \
make zImage

xen image I used:
git clone git://xenbits.xen.org/xen.git
git checkout stable-4.4
export CONFIG_EARLY_PRINTK=exynos5250
export ARCH=arm
export CROSS_COMPILE=arm-linux-gnueabi-
make dist-xen XEN_TARGET_ARCH=arm32

for xen-uImage:
mkimage -A arm -T kernel -a 0x80200000 -e 0x80200000 -C none -d "../xen/xen" xen-uImage

And, replace env script
setenv initrd_high "0xffffffff"
setenv fdt_high "0xffffffff"
setenv kernel_addr_r 0x60000000
setenv xen_addr_r 0x50000000
setenv bootcmd_load_linux_mmc 'fatload mmc 0:2 $kernel_addr_r /zImage'
setenv boot_xen_mmc 'run bootcmd_load_linux_mmc; fatload mmc 0:2 $xen_addr_r /xen-uImage; bootm $xen_addr_r -'
setenv bootcmd 'run boot_xen_mmc'
setenv bootargs "console=tty0 console=ttySAC3,115200n8 Âroot=UUID=033f7255-a182-45e9-bf46-331666c414f4 rootwait ro"

Any suggestion would be very appreciated for us.

Thank you.


On Fri, Apr 11, 2014 at 9:27 AM, Julien Grall <julien.grall@xxxxxxxxxx> wrote:
On 04/11/2014 02:17 PM, Meng Xu wrote:
> Hi Julien,


> Thank you so much for your reply!
> Â Â > We have a Samsung Exynos 5420 Arndale Octa Board. We tried to run Xen
> Â Â > 4.4 on the Arndale Octa board.
> Â Â Xen 4.4 only supports the Arndale 5250. AFAIK, the octa has a similar
> Â Â layout as 5250. Porting Xen on the board should not be too difficult.
> Â Â I know there is some people who are working on porting Xen to the odroid
> Â Â xu which also have an exynos inside.
> Great! Do you know if they have any timeline on this or any patch we
> could try?

I cced a person who is working on the odroid XU. He may be able to tell
you if he plans to send patch upstream.

> Â Â > We have successfully to run Ubuntu on that board by customizing
> Â Â the UBoot.
> Â Â Does your U-boot bring up CPU in hypervisor mode?
> Sorry, can I ask a silly question:
> How should I check if U-boot bring up CPU in hypervisor mode?
> When we run Ubuntu successfully, we didn't use Xen at all. (Of course,
> it doesn't affect us to check if Uboot bring up CPU in hypervisor mode.)

When you will have early printk enabled in Xen. It will let you know if
the CPUs are in hypervisor mode or not.


Julien Grall

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.