[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen-ARM couldn't boot up

The command line comes from device tree, so you need to change
xen,dom0-bootargs in the DTS, build it again and rebuild Xen with the
updated DTB.

On Thu, 7 Mar 2013, Josh Zhao wrote:
> Hi Ian,
> Thanks for answering my questions. I use gnome-terminal instead of xterm, now 
> It works as what I want. I
> tried use motherboard.mmc.p_mmc_file=vexpress.img which I downloaded from 
> linaro. The terminal1 still has
> "VFS: Cannot open root device "mmcblk0" or unknown-block(0,0): error -6" 
> issue. So I modifiedÂ
> CONFIG_CMDLINE="earlyprintk=xenboot console=ttyAMA1 root=/dev/nfs 
> nfsroot= rw
> ip=dhcp" in .config file and re-compiled kernel.
> I run it again but it still has the "mmcblk0 ..." problem. I was wondering 
> how Dom0 kernel get the command
> line?
> Thanks,
> josh zhao
> Â
> 2013/3/6 Ian Campbell <ian.campbell@xxxxxxxxxx>
>       On Wed, 2013-03-06 at 02:47 +0000, Josh Zhao wrote:
>       > (1) How I pass the FS image to Dom0 kernel?
> -C motherboard.mmc.p_mmc_file=<filename>
> > (2) I am wondering how to redirect model_shell's terminals output into
> > a file? ÂBecause I couldn't Âcopy the output from the terminals.
> Can't you? The terminals are just xterm+telnet's to localhost, by
> default port 5000+N but you can change that with -C
> motherboard.terminal_0.start_port=FOO, I'd have thought cut-n-paste woud
> just work. You could use -C motherboard.terminal_0.start_telnet=0 to
> disable the automatic telnet and use whatever you like (e.g. netcat to a
> file) instead.
> I'm pretty sure all of this is in the fast models documentation and you
> can see the list of options by passing the -l option.
> Ian.
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.