[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Need help with qemu args debug

On 06/03/12 14:18, Fantu wrote:
Stefano Stabellini-3 wrote

There is nothing on the logs but SPICE, unfortunately.
You might have to add few printf to QEMU to see how far it is able to
go. For example block.c:bdrv_open.

Problem found, device not found is caused by maxmem parameter,domU S.O.
starts without maxmem, probably there are same unexpected cases on xen
and/or seabios with ram and videoram allocation.
I tried searching but could not find the solution to make allocation of ram
and videoram works with more than standard values.

I tried to reproduce this, but I did not have any issue (with an iso). Also I could not understand why maxmem will have an issue with a drive. Also, spice+qemu on debian does not work well, so I'm not sure if I will have the same issue. When you found the issue related to the "device not found", do you have run the VM without qxl and spice ?

I've just send a patch that fix a memory mapping issue (at least for me), could you try with it? :

Then, do you have the same issue if you use an .iso instead of /dev/sr0 as a cdrom ?

Anthony PERARD

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.