[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] audio device pass-through on HVM guest not working...


I tried two ways to play audio form HVM guest (ubuntu-12.04): with and without Audio device pass-through. Both could not work successfully. In fact, my ultimate goal is to pass through the sound device.

The HVM guest can play audio, but there is no sound. I used PC speaker as well as headphone, it does work at all.

The HVM guest perfectly works fine for networking and the sound card and PC speaker on the host are working fine too.

The HVM is emulated using qemu-xen.

Below is my setup. I know it is too much informatio below, but it will give you sufficient information.  I am doing my master thesis. And it took many days to figure it out. your help is v. much appreciated :)

hypervisor: xen-4.1 from Ubuntu-12.04
sound card:
$ lspci -k
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
    Subsystem: Hewlett-Packard Company Device 3398
    Kernel modules: snd-hda-intel
hvm guest configuration:
virsh # domxml-to-native xen-xm hvm.xml
name = "swart-4.3"
uuid = "2f4a71f5-75d7-e706-dfa7-5cf4c946c2c2"
maxmem = 1024
memory = 1024
vcpus = 1
builder = "hvm"
kernel = "/usr/lib/xen-default/boot/hvmloader"
boot = "c"
pae = 1
acpi = 1
apic = 1
hap = 0
viridian = 0
localtime = 0
hpet = 0
>>>device_model = "/usr/lib/xen-default/bin/qemu-dm"
sdl = 0
vnc = 1
vncunused = 1
keymap = "en-us"
disk = [ "file:/var/lib/libvirt/images/swart-4.3.img,hda,w", ",hdc:cdrom,r" ]
vif = [ "mac=00:16:3e:31:dc:3f,bridge=virbr0,script=vif-bridge,model=e1000,vifname=vif4.0" ]
parallel = "none"
serial = "pty"
soundhw = "ac97" // I tried with es1370, sb16,pcspk, but could not work.

From HVM guest, the sound card  information looks like this

$aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: I82801AAICH [Intel 82801AA-ICH], device 0: Intel ICH [Intel 82801AA-ICH]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

$lspci -v
.0 Multimedia audio controller: Intel Corporation 82801AA AC'97 Audio Controller (rev 01)
    Subsystem: Intel Corporation Device 0000
    Flags: bus master, medium devsel, latency 64, IRQ 36
    I/O ports at c000 [size=1K]
    I/O ports at c500 [size=256]
    Kernel driver in use: snd_intel8x0
    Kernel modules: snd-intel8x0

IO virtualization
$xm dmesg
(XEN) Intel VT-d Snoop Control not enabled.
(XEN) Intel VT-d Dom0 DMA Passthrough not enabled.
(XEN) Intel VT-d Queued Invalidation enabled.
(XEN) Intel VT-d Interrupt Remapping enabled.
(XEN) Intel VT-d Shared EPT tables not enabled.
(XEN) I/O virtualisation enabled

Thank you,



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.