[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Bug#708344: Serial Passthrough broken in Debian Wheezy?

Hello Ian,

first, thanks for the advices to further debug this issue. Your help is really appreciated!

Am 2013-06-05 12:11, schrieb Ian Campbell:
Thanks. I'm taking this to xen-devel and moving the other two lists to
bcc. For xen-devel the background can be found at

The gist is that with:
        irq         = [ 4 ]
        ioports     = [ '3f8-3ff' ]

in the guest config the serial port used to work with Jeremy's xen.git
(used in Squeeze) but doesn't work with Wheezy (3.2 based) or a 3.9
kernel. The smstools daemon fails with:
Cannot open serial port /dev/ttyS0, error: Function not implemented

Jonas' dmesg shows:
[    0.196892] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[    0.217565] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

and /proc/ioports shows the region but /proc/interrupts does not AFAICT. I can't see any interrupt related errors. Jonas can you confirm that the
dmesg includes the logs resulting from an attempt to open the device?

No, unfortunately I can not. With any new kernel (3.2 or 3.9), no messages appear in dmesg when either smsd or picocom try to connect to the serial port.

Jonas, could you try a few more experiments, if you don't mind:

Sure. Unfortunately I don't have much experiences with serial ports, so you might need to give more advices.

Can you use something simpler (like picocom) rather than smsdaemon and
see if that works.

I tried to open with picocom ('picocom /dev/ttyS0'). It resulted in the following error output:

# picocom /dev/ttyS0
picocom v1.7

port is        : /dev/ttyS0
flowcontrol    : none
baudrate is    : 9600
parity is      : none
databits are   : 8
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv
imap is        :
omap is        :
emap is        : crcrlf,delbs,

FATAL: failed to add device /dev/ttyS0: Filedes is not a tty

Assuming not could you strace it so we can see what
is actually failing. If those attempts result in anything extra in the
dmesg please can you post it.

I tried 'strace -o strace.log -ff -s 1024 -v smsd -u smsd -g dialout -t'. All resulting strace.log.* Logfiles are attached. I guess that strace.log.4521 is the interesting one. At least this is the only logfile that contains 'ttyS0'.

It ought to be possible to set the port to polled mode, I think by
setting the IRQ to -1 with setserial or I think it should be possible on
the command line but I can't seem to figure out how... Anyway, if you
can get that to work it might be interesting...

Sorry, don't know nothing about this. What is 'polled mode'? I'm happy to do more testing, but would need more detailed advices ;)

Kind regards,

Attachment: strace.log.4493
Description: Text document

Attachment: strace.log.4515
Description: Text document

Attachment: strace.log.4517
Description: Text document

Attachment: strace.log.4521
Description: Text document

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.