[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] DomU suspension/hibernation

  • To: Ian Murray <murrayie@xxxxxxxxxxx>, "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: Joshua Tuttle <jtuttle@xxxxxxxxx>
  • Date: Tue, 18 Jun 2013 18:44:25 +0000
  • Accept-language: en-US
  • Delivery-date: Tue, 18 Jun 2013 18:45:58 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>
  • Thread-index: Ac5sNZm8/BGodeLXTI6gjI/2RebG7gAA4oSAAAAl8JAABNbyAAABm8IA
  • Thread-topic: [Xen-users] DomU suspension/hibernation

-----Original Message-----
From: xen-users-bounces@xxxxxxxxxxxxx [mailto:xen-users-bounces@xxxxxxxxxxxxx] 
On Behalf Of Ian Murray
Sent: Tuesday, June 18, 2013 1:56 PM
To: xen-users@xxxxxxxxxxxxx
Subject: Re: [Xen-users] DomU suspension/hibernation

On 18/06/13 16:42, Joshua Tuttle wrote:
> -----Original Message-----
> From: Ian Campbell [mailto:Ian.Campbell@xxxxxxxxxx]
> Sent: Tuesday, June 18, 2013 11:33 AM
> To: Joshua Tuttle
> Cc: xen-users@xxxxxxxxxxxxx
> Subject: Re: [Xen-users] DomU suspension/hibernation
> On Tue, 2013-06-18 at 15:16 +0000, Joshua Tuttle wrote:
>> Hey,
>> I thought there was supposed to be an ability for domUâs to be put
>> into a hibernated state (E.g. current running tasks and memory) when
>> dom0 is shutdown or rebooted. When
>> I look in my /etc/default/xendomains file, I have the variableâs
>> âXENDOMAINS_SAVE=/var/lib/xen/saveâ and âXENDOMAINS_RESTORE=trueâ.
>> However, when I reboot, I always have
>> to restart my domains manually and their state was not saved.
>> My current configuration is as follows: Xen 4.2.1, dom0: Debian 7.0,
>> domU:Debian 7.0, dom0 kernel 3.2.0-4
> Are you using the Debian packages or Xen compiled from source?
> Which toolstack are you using?
> If you installed from source, did you enable the xendomains script
> when you did so? (by invoking update-rc.d or something equivalent)
> Does manually running xendomains ("service xendomains stop" then "service 
> xendomains start") produce any output?
> Ian.
> I am using Xen compiled from source. 4.2.1 and the XL toolstack.
> I ran update rc.d on xecommons, xend, xendomains, xen-watchdog.
> Xend can probably be disabled, I'm not sure if having it running would be 
> causing a problem.
> Manually stopping xendomains produces a line that confirms xendomains is 
> stopped.
> Starting xendomains produces no output, but I check the service with "xl list"

Have a read of http://osdir.com/ml/general/2013-05/msg46973.html and see if 
this is the same issue (sorry for not linking directly to Xen, Google seems to 
link to the wrong message when I follow its links).

If it is the same issue, then a patch has been submitted and accepted which I 
believe is destined for 4.3. Also, there was an issue around the regex stuff 
which got cleared up by a previous patch that I traced back to yaji (maybe!). I 
don't know when the other fix came in, so you may need to go to 4.22 to apply 
the linked patch.

Thanks for replying.

I applied a patch " hotplug/Linux: xendomains compatibility with xl" , but 
still have had no luck. The only thing it fixed, is if I place a symlink to my 
config file in /etc/xen/auto, it will automatically start the domU instance. 
However, its still not putting a previous instance into a hibernated state.
Xen-users mailing list

This message and all attachments are PRIVATE, and contain information that is 
PROPRIETARY to Intelligent Automation, Inc. You are not authorized to transmit 
or otherwise disclose this message or any attachments to any third party 
whatsoever without the express written consent of Intelligent Automation, Inc. 
If you received this message in error or you are not willing to view this 
message or any attachments on a confidential basis, please immediately delete 
this email and any attachments and notify Intelligent Automation, Inc.
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.