|
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH v3 2/6] xen/riscv: rename PTE "permissions" to "pte_flags"
On 9/30/26 2:07 PM, Jan Beulich wrote: On 29.09.2026 18:32, Baptiste Le Duc wrote:paddr_to_pte()'s "permissions" parameter, the matching local in setup_initial_mapping() and p2m_set_permission() don't only deal with permission bits: they also handle PTE_VALID, PTE_USER, PTE_ACCESSED and PTE_DIRTY. Rename them to "pte_flags" and p2m_set_pte_flags() respectively. No functional change. Requested-by: Jan Beulich <jbeulich@xxxxxxxx> Assisted-by: Claude:claude-opus-5 Signed-off-by: Baptiste Le Duc <baptiste.le-duc@xxxxxxxxxx>In principle Acked-by: Jan Beulich <jbeulich@xxxxxxxx> I won't, however, be able to apply this patch as-is. As you can see both above and below, extra newlines were inserted everywhere on the way here. The list archive doesn't show this issue, but instead shows undue wrapped lines. It is also only this one patch in the series which has this issue. You will need to resend for me to properly consume. I had the same issue but I resolved it with a small bash script. ~ Oleksii
|
![]() |
Lists.xenproject.org is hosted with RackSpace, monitoring our |