[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [PATCH 17/26] hw/usb/bus: Rename usb_get_dev_path() as usb_get_full_dev_path()
On Sat, Jul 4, 2020 at 7:58 AM Philippe Mathieu-Daudé <f4bug@xxxxxxxxx> wrote: > > If the device has USB_DEV_FLAG_FULL_PATH set, usb_get_dev_path() > returns the full port path. Rename the function accordingly. > > Signed-off-by: Philippe Mathieu-Daudé <f4bug@xxxxxxxxx> Reviewed-by: Alistair Francis <alistair.francis@xxxxxxx> Alistair > --- > hw/usb/bus.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/hw/usb/bus.c b/hw/usb/bus.c > index f8901e822c..fad8194bf5 100644 > --- a/hw/usb/bus.c > +++ b/hw/usb/bus.c > @@ -13,7 +13,7 @@ > > static void usb_bus_dev_print(Monitor *mon, DeviceState *qdev, int indent); > > -static char *usb_get_dev_path(DeviceState *dev); > +static char *usb_get_full_dev_path(DeviceState *dev); > static char *usb_get_fw_dev_path(DeviceState *qdev); > static void usb_qdev_unrealize(DeviceState *qdev); > > @@ -33,7 +33,7 @@ static void usb_bus_class_init(ObjectClass *klass, void > *data) > HotplugHandlerClass *hc = HOTPLUG_HANDLER_CLASS(klass); > > k->print_dev = usb_bus_dev_print; > - k->get_dev_path = usb_get_dev_path; > + k->get_dev_path = usb_get_full_dev_path; > k->get_fw_dev_path = usb_get_fw_dev_path; > hc->unplug = qdev_simple_device_unplug_cb; > } > @@ -577,7 +577,7 @@ static void usb_bus_dev_print(Monitor *mon, DeviceState > *qdev, int indent) > dev->attached ? ", attached" : ""); > } > > -static char *usb_get_dev_path(DeviceState *qdev) > +static char *usb_get_full_dev_path(DeviceState *qdev) > { > USBDevice *dev = USB_DEVICE(qdev); > > -- > 2.21.3 > >
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |