[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [PATCH 00/26] hw/usb: Give it love, reduce 'hw/usb.h' inclusion out of hw/usb/
Hi, This is the second time I try to replace a magic typename string by a constant, and Zoltan warns me this is counter productive as "hw/usb.h" pulls in an insane amount of code. Time to give the usb subsystem some love and move forward. This series can be decomposed as follow: 1-2: preliminary machine cleanups (arm/ppc) 3-13: usb related headers cleanups 14-15: usb quirks cleanup 16-18: refactor usb_get_dev_path() to add usb_get_port_path() 19: let spapr use usb_get_port_path() to make USBDevice opaque 20: extract the public USB API (for machine/board/soc) 21: make the older "usb.h" internal to hw/usb/ 22-25: use TYPENAME definitions 26: cover dwc2 in MAINTAINERS Please review. Phil. Philippe Mathieu-Daudé (26): hw/arm/sbsa-ref: Remove unused 'hw/usb.h' header hw/ppc/sam460ex: Add missing 'hw/pci/pci.h' header hw/usb: Remove unused VM_USB_HUB_SIZE definition hw/usb: Reduce 'exec/memory.h' inclusion hw/usb/desc: Add missing header hw/usb/hcd-dwc2: Remove unnecessary includes hw/usb/hcd-dwc2: Restrict some headers to source hw/usb/hcd-dwc2: Restrict 'dwc2-regs.h' scope hw/usb/hcd-ehci: Remove unnecessary include hw/usb/hcd-ehci: Move few definitions from header to source hw/usb/hcd-xhci: Add missing header hw/usb/hcd-musb: Restrict header scope hw/usb/desc: Reduce some declarations scope hw/usb/quirks: Rename included source with '.inc.c' suffix hw/usb: Add new 'usb-quirks.h' local header hw/usb/bus: Simplify usb_get_dev_path() hw/usb/bus: Rename usb_get_dev_path() as usb_get_full_dev_path() hw/usb/bus: Add usb_get_port_path() hw/ppc/spapr: Use usb_get_port_path() hw/usb: Introduce "hw/usb/usb.h" public API hw/usb: Move internal API to local 'usb-internal.h' header hw/usb/usb-hcd: Use OHCI type definitions hw/usb/usb-hcd: Use EHCI type definitions hw/usb/usb-hcd: Use UHCI type definitions hw/usb/usb-hcd: Use XHCI type definitions MAINTAINERS: Cover dwc-hsotg (dwc2) USB host controller emulation hw/usb/desc.h | 11 +++++ {include/hw => hw}/usb/dwc2-regs.h | 0 hw/usb/hcd-dwc2.h | 5 +- hw/usb/hcd-ehci.h | 24 +--------- {include/hw => hw}/usb/hcd-musb.h | 2 + hw/usb/hcd-ohci.h | 4 +- hw/usb/hcd-xhci.h | 4 +- include/hw/usb.h => hw/usb/usb-internal.h | 50 ++----------------- hw/usb/usb-quirks.h | 27 +++++++++++ include/hw/usb/chipidea.h | 2 +- include/hw/usb/usb-hcd.h | 36 ++++++++++++++ include/hw/usb/usb.h | 58 +++++++++++++++++++++++ chardev/baum.c | 2 +- hw/arm/allwinner-a10.c | 2 +- hw/arm/allwinner-h3.c | 10 ++-- hw/arm/exynos4210.c | 2 +- hw/arm/pxa2xx.c | 3 +- hw/arm/realview.c | 3 +- hw/arm/sbsa-ref.c | 4 +- hw/arm/versatilepb.c | 3 +- hw/arm/xilinx_zynq.c | 2 +- hw/display/sm501.c | 3 +- hw/i386/pc.c | 2 +- hw/i386/pc_piix.c | 5 +- hw/i386/pc_q35.c | 15 +++--- hw/isa/piix4.c | 3 +- hw/mips/fuloong2e.c | 5 +- hw/ppc/mac_newworld.c | 5 +- hw/ppc/mac_oldworld.c | 3 +- hw/ppc/sam460ex.c | 6 ++- hw/ppc/spapr.c | 13 +++-- hw/sh4/r2d.c | 2 +- hw/usb/bus.c | 40 +++++++++------- hw/usb/chipidea.c | 1 + hw/usb/combined-packet.c | 2 +- hw/usb/core.c | 2 +- hw/usb/desc-msos.c | 2 +- hw/usb/desc.c | 3 +- hw/usb/dev-audio.c | 2 +- hw/usb/dev-hid.c | 2 +- hw/usb/dev-hub.c | 2 +- hw/usb/dev-mtp.c | 2 +- hw/usb/dev-network.c | 2 +- hw/usb/dev-serial.c | 2 +- hw/usb/dev-smartcard-reader.c | 2 +- hw/usb/dev-storage.c | 2 +- hw/usb/dev-uas.c | 2 +- hw/usb/dev-wacom.c | 2 +- hw/usb/hcd-dwc2.c | 8 ++-- hw/usb/hcd-ehci-sysbus.c | 1 + hw/usb/hcd-ehci.c | 13 ++++- hw/usb/hcd-musb.c | 4 +- hw/usb/hcd-ohci-pci.c | 4 +- hw/usb/hcd-ohci.c | 1 - hw/usb/hcd-uhci.c | 21 ++++---- hw/usb/hcd-xhci-nec.c | 3 +- hw/usb/hcd-xhci.c | 2 +- hw/usb/host-libusb.c | 2 +- hw/usb/host-stub.c | 2 +- hw/usb/libhw.c | 2 +- hw/usb/quirks.c | 5 +- hw/usb/{quirks.h => quirks.inc.c} | 5 -- hw/usb/redirect.c | 3 +- hw/usb/tusb6010.c | 4 +- hw/usb/xen-usb.c | 2 +- monitor/misc.c | 2 +- softmmu/vl.c | 2 +- MAINTAINERS | 7 ++- 68 files changed, 294 insertions(+), 185 deletions(-) rename {include/hw => hw}/usb/dwc2-regs.h (100%) rename {include/hw => hw}/usb/hcd-musb.h (98%) rename include/hw/usb.h => hw/usb/usb-internal.h (92%) create mode 100644 hw/usb/usb-quirks.h create mode 100644 include/hw/usb/usb-hcd.h create mode 100644 include/hw/usb/usb.h rename hw/usb/{quirks.h => quirks.inc.c} (99%) -- 2.21.3
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |