[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Unable to boot Dom0 on Hikey

Thanks for your feedback. Yes, I'm using "HiKey" that I recently bought. I tried RELEASE-4.9.0 and RELEASE-4.8.0 and RELEASE-4.7.3. None of them boots. There were little differences. Xen 4.8 printed one line more and stopped:
(XEN) Freed 268kB init memory.
(XEN) Hardware Dom0 shutdown: rebooting machine
Xen 4.9 rebooted after it failed to boot.

Do you think the issue is with the Xen version?

This is how I build Xen:
cd xen/xen
export CROSS_COMPILE=aarch64-linux-gnu-
export ARCH=arm64
export XEN_TARGET_ARCH=arm64
make defconfig
make -j8

Should I make specific config for HiKey?

And in this link: https://lists.gt.net/xen/devel/433472, they could boot the system by disabling the USB_DWC2 in the kernel. I tried modifying the .config file directly and disabling the ones related to USB_DWC2  (commenting the line out) but when I tried rebuilding the kernel it restarted generating the .config file. So I couldn't apply this comment.

Saeed Mirzamohammadi
Ph.D. candidate
Computer Science Department
University of California, Irvine

On Tue, Aug 29, 2017 at 7:12 AM, Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> wrote:
On Mon, Aug 28, 2017 at 06:23:41PM -0700, Saeed Mirzamohammadi wrote:
> Hi,
> I'm following instructions on https://wiki.xenproject.org/wiki/HiKey and
> https://github.com/Jeeppler/xen-note/blob/master/
> arm64/hikey/hikey-xen-centos.md.

And just to make sure, you are using HiKey not Hikey960. There is a big
difference between them and you can only buy Hikey960 nowadays.

CC-ed Stefano
> I'm trying to boot Xen on Hikey but Dom0 doesn't boot after Xen! I can boot
> the linux individually with startup.sh. This works fine but when I try to
> boot xen (typing 4 and then xen), I get a couple of Xen messages and when
> it tries to boot Dom0 it fails and it stops there.These are the last
> messages:
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> (XEN) *** LOADING DOMAIN 0 ***
> (XEN) Loading kernel from boot module @ 000000007a029000
> (XEN) Loading ramdisk from boot module @ 000000000ae00000
> (XEN) Allocating 1:1 mappings totalling 512MB for dom0:
> (XEN) BANK[0] 0x00000040000000-0x00000060000000 (512MB)
> (XEN) Grant table range: 0x00000005c00000-0x00000005c5e000
> (XEN) Loading zImage from 000000007a029000 to
> 0000000040080000-0000000040ce8400
> (XEN) Loading dom0 initrd from 000000000ae00000 to
> 0x0000000048200000-0x0000000048a00000
> (XEN) Allocating PPI 16 for event channel interrupt
> (XEN) Loading dom0 DTB to 0x0000000048000000-0x000000004800aec1
> (XEN) Scrubbing Free RAM on 1 nodes using 8 CPUs
> (XEN) ..done.
> (XEN) Initial low memory virq threshold set at 0x4000 pages.
> (XEN) Std. Loglevel: All
> (XEN) Guest Loglevel: All
> (XEN) *** Serial input -> DOM0 (type 'CTRL-x' three times to switch input
> to Xen)
> (XEN) Freed 276kB init memory.
> (XEN) traps.c:2505:d0v0 HSR=0x92000061 pc=0xffffffc0003f86ac
> gva=0xffffff800024000c gpa=0x00000021fc000c
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> My Xen version is: 4.7.0.rc4 and my dom0 is: android-hikey-linaro-4.1. I

That is a bit old. How about Xen 4.9?

> tried earlier Xen version but no difference.
> This is my *xen.cfg*:
> options=dom0_mem=512M dom0_max_vcpus=4 conswitch=x console=dtuart
> dtuart=/smb/uart@f7113000
> kernel=Image console=hvc0 root=/dev/mmcblk0p9 rootwait rw 3
> dtb=hi6220-hikey.dtb
> and my *startup.nsh*:
> FS0:
> Image dtb=hi6220-hikey.dtb console=ttyAMA3,115200 root=/dev/mmcblk0p9
> rootwait rw efi=noruntime
> I've checked out the thread here or others: https://lists.gt.net/
> xen/devel/433472 but I have passed the dtb file in the xen.cfg and still
> Dom0 doesn't boot.
> Any help is greatly appreciated.
> Thanks a lot,
> --
> Saeed Mirzamohammadi
> Ph.D. candidate
> Computer Science Department
> University of California, Irvine

> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxx
> https://lists.xen.org/xen-devel

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.