[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH V2 3/25] VIOMMU: Add get irq info callback to convert irq remapping request
On 2017年08月22日 23:38, Roger Pau Monné wrote: > On Wed, Aug 09, 2017 at 04:34:04PM -0400, Lan Tianyu wrote: >> This patch is to add get_irq_info callback for platform implementation >> to convert irq remapping request to irq info (E,G vector, dest, dest_mode >> and so on). >> >> Signed-off-by: Lan Tianyu <tianyu.lan@xxxxxxxxx> >> --- >> xen/common/viommu.c | 16 ++++++++++++++++ >> xen/include/asm-x86/viommu.h | 8 ++++++++ >> xen/include/xen/viommu.h | 9 +++++++++ >> 3 files changed, 33 insertions(+) >> >> diff --git a/xen/common/viommu.c b/xen/common/viommu.c >> index f4d34e6..03c879d 100644 >> --- a/xen/common/viommu.c >> +++ b/xen/common/viommu.c >> @@ -213,6 +213,22 @@ int viommu_handle_irq_request(struct domain *d, u32 >> viommu_id, >> return info->viommu[viommu_id]->ops->handle_irq_request(d, request); >> } >> >> +int viommu_get_irq_info(struct domain *d, u32 viommu_id, >> + struct irq_remapping_request *request, >> + struct irq_remapping_info *irq_info) > > The definition of this struct seems to be arch-specific, in which case > IMHO it should be called arch_irq_remapping_info, in order to denote > it's arch-specific. OK. Will update. > >> +{ >> + struct viommu_info *info = &d->viommu; >> + >> + if ( viommu_id >= info->nr_viommu >> + || !info->viommu[viommu_id] ) > > Unneeded line break. > > Roger. > _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx https://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |