[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH] hvm: vmx/svm_cpu_up_prepare should be called only once



On 17/08/17 15:19, Boris Ostrovsky wrote:
> diff --git a/xen/arch/x86/hvm/svm/svm.c b/xen/arch/x86/hvm/svm/svm.c
> index 0dc9442..3e7b9fc 100644
> --- a/xen/arch/x86/hvm/svm/svm.c
> +++ b/xen/arch/x86/hvm/svm/svm.c
> @@ -1538,7 +1538,7 @@ static int _svm_cpu_up(bool bsp)
>          return -EINVAL;
>      }
>  
> -    if ( (rc = svm_cpu_up_prepare(cpu)) != 0 )
> +    if ( bsp && (rc = svm_cpu_up_prepare(cpu)) != 0 )
>          return rc;

Why not call svm_cpu_up_prepare(cpu) in the caller of the bsp path,
dropping this clause entirely?

~Andrew

_______________________________________________
Xen-devel mailing list
Xen-devel@xxxxxxxxxxxxx
https://lists.xen.org/xen-devel

 


Rackspace

Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.