[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH v2 03/18] x86/traps: lift do_guest_trap to domain.h

>>> On 12.05.17 at 20:16, <andrew.cooper3@xxxxxxxxxx> wrote:
> On 05/05/17 15:48, Wei Liu wrote:
>> Put it along side with other pv_inject functions and rename it to
>> pv_inject_trap.
>> We need this because this function is used by PV emulation code and PV
>> trap handling code, which will be split into different files.
>> No functional change.
>> Signed-off-by: Wei Liu <wei.liu2@xxxxxxxxxx>
> On further thought, it might be better to use this patch instead, which
> drops do_guest_trap() in favour of better alternatives, and in a manor
> more consistent with HVM guests.
> Thoughts?

Yes please.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.