[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen 4.6 Development Update (three months reminder)

Il 29/04/2015 12:23, Fabio Fantoni ha scritto:
Il 29/04/2015 02:21, Andrew Cooper ha scritto:
On 28/04/15 23:17, Jim Fehlig wrote:
Jim Fehlig wrote:
wei.liu2@xxxxxxxxxx wrote:
Hi all

We are now three months into 4.6 development window. This is an email to keep track of all the patch series I gathered. It is by no means complete and / or acurate. Feel free to reply this email with new projects or correct my
*  libxl: add qxl vga interface support for upstream qemu (fair)
   -  Fabio Fantoni
I've been working on SPICE support in the libvirt libxl driver and
quickly came across the lack of support for qxl device. What is the
status of this work?  AFAICT, there was a v16 posted nearly a year ago
with no comments

After playing with this more, I think the patch will need a
LIBXL_HAVE_QXL or similar in libxl.h.

I noticed this work was committed in the 4.3 dev cycle, but was reverted
before the release by commit 5479961a, which describes problems with
"instructions that cannot be used for MMIO". Has any progress been made
on that front?  Is Fabio's patch the only piece missing to support qxl
I've tried Fabio's patch on top of fairly recent xen-unstable and don't
see the issues mentioned in the commit message of 5479961a. Note that I
only tried linux HVM guests though.

qxl vga is working good on windows domUs except problem after save/restore
on linux domUs instead I wasn't able to get it working
today I tried with fedora 22 (beta3) lxde live dvd (have included latest qxl drivers available): with both stdvga and qxl mouse is working but not visible and I not understand why, I'll try also lubuntu 15.04.
can you tell me what dom0 and domU have you use for test please?

16byte decomposed instruction still don't get passed correctly to the device model.

This has been discussed at the hackathon and plan is in place.


Thanks, is there any eta of possible solution?

Thanks for any reply and sorry for my bad english.

I tried with lubuntu 15.04 with qxl on latest xen-unstable and qemu crashed:
#0  __memset_sse2 () at ../sysdeps/x86_64/multiarch/../memset.S:908
Latest istruction:
=> 0x7ffff3713f7b <__memset_sse2+2363>:    movntdq %xmm0,(%rdi)

In attachment full backtrace, registers, istructions ecc... if can be useful

The linux domUs problem with qxl seems related to what Andrew told.

Added also Jan Beulich, he did one or more patches for try to solves it time ago if I remember good.

Attachment: qemu-xen-gdb.log
Description: Text document

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.