[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] RFC: Cleaning up the Mini-OS namespace


Martin Lucina, le Thu 04 Dec 2014 15:27:57 +0100, a écrit :
> - Is there a general interest in upstreaming this work?

I believe so.  That can only help people using minios.

> - All Mini-OS functions called by rumprun-xen are renamed to minios_* or
>   _minios_* for strictly internal functions, except those in the
>   blkfront_*, netfront_*, pcifront_* and xenbus_* driver namespaces.

That looks fine.

> - In the case of drivers, eg. init|shutdown_blkfront are renamed to
>   blkfront_*.

Right, good thing :)

> - All global variables are either manually made local, or placed under
>   the _minios_* namespace, with the exception of HYPERVISOR_shared_info,
>   and those variables under driver namespaces kept above.

That looks fine too.

> - All callers are updated to use the new names. Where it makes sense,
>   macros such as alloc_page are also renamed into the minios_ namespace.

The stubdom/ directory needs to be updated too, as well as the
qemu-stubdom directory (I unfortunately don't know where it is
maintained ATM).

> - Upstream Mini-OS provides things we (rumpkernel.org) don't need (stub
>   "libc", ...). If we are to move to upstream then we will need to do a
>   more general cleanup of Mini-OS to make these pluggable. Again, is there
>   upstream interest in this work?

Yes.  It should be feasible to make the tiny libc inside minios
pluggable, so you can plug things a better way for you. It's fine to
have #ifdefs in extra/mini-os/lib/

> - As there is no formal API for Mini-OS. My changes only address the
>   "public" functionality used by rumprun-xen. Other users mileage will
>   vary; who else should I coordinate with?

I guess anybody who will have seen this thread on this list :)

> - I have not namespaced macros such as local_irq_save(). Should this be
>   done? 

It should be fine not to do it.

>   Also, the driver namespaces have been preserved (since I was lazy), these
>   should probably be renamed under the minios namespace; it's plausible
>   some day someone will try to link an application with a function called
>   blkfront_init().

I'd say that while we are breaking the existing API, let's do it for
good and rename the driver namespace too.

Providing a header with backward-compatibility renaming macros for all
of this would however be useful, to be nicer to out-of-tree users.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.