[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Is: QXL in Xen (busted) Was :Re: Xen 4.5-rc1 update (RC1 is out 2014-Oct-24th)

2014-10-28 18:18 GMT+01:00 Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>:
On Tue, Oct 28, 2014 at 02:22:06PM +0100, Fabio Fantoni wrote:
> Il 27/10/2014 17:15, Konrad Rzeszutek Wilk ha scritto:
> >On Sat, Oct 25, 2014 at 10:10:29AM +0200, Fabio Fantoni wrote:
> >>Il 24/10/2014 20:08, konrad.wilk@xxxxxxxxxx ha scritto:
> >>>Feature patchsets that did not make it in by today have been put
> >>>on the deferred list. If you think your feature should make it in Xen 4.5-rc2
> >>>please make your case.
> >>>
> >>>Xen 4.5-rc1 is out today. There are some issues (see 'Known Issues' below)
> >>>which are to be fixed in RC2. The official test-day is on Wednesday (Oct 29th)
> >>>but if you want to start testing it today - please do!
> >>>
> >>>Details for the test-day are at
> >>>
> >>>http://wiki.xen.org/wiki/Xen_4.5_RC1_test_instructions
> >>>
> >>>In terms of bugs, we have:
> >>>
> >>>#6 linux: pv drivers miss shutdown command if issued too early
> >>>#8 "linux, xenbus mutex hangs when rebooting dom0 and guests hung."
> >>>#11 qxl hypervisor support
> >>About qxl latest version of libxl/xl support patch is here (also posted to
> >>xen-devel) and should be ok:
> >>https://github.com/Fantu/Xen/commit/9d9d0ae23ab3e3e1fcfbb6f3201d3a79f958a7a3
> >which is aab4d1b266ce9891a684704f6abf6a5f6b3f7c24 upstrem.
> Was applied upstream for 4.3 and after removed because linux domUs problem
> was not solved before stable release.
> In github I put also a newer version with some improvements.

Ah, so this is a new version that had not yet been posted on xen-devel?

I always posted all versions of the patch in xen-devel, the latest was long time ago.

It is Xen 4.5 RC1 so I am not too thrilled to put this in the release,
especially as it sounds like there are still problems to figure out first.

Changing the title to reflect this.
> >
> >>With xen 4.5 qxl vga in windows 7 64 bit domUs seems that works good as kvm
> >>except for a strange problem with xl save/restore.
> >Could you paste in your guest config please.
> name='W7-02'
> builder="hvm"
> memory=2048
> vcpus=2
> acpi_s3=0
> acpi_s4=0
> vif=['bridge=xenbr0,mac=00:16:3e:42:a2:5f']
> disk=['/mnt/vm/disks/W7-02.disk1.xm,raw,hda,rw',',raw,hdb,ro,cdrom']
> boot='dc'
> device_model_version="qemu-xen"
> viridian=1
> vnc=0
> keymap="it"
> > > vga="qxl"
> spice=1
> spicehost=''
> spiceport=6003
> spicedisable_ticketing=1
> spicevdagent=1
> spice_clipboard_sharing=0
> spiceusbredirection=4

Does SPICE always have to be enabled to use QXL?

Without spice and its driver qxl works only as stdvga.
Without qxl spice is better that vnc to use it as "vkvm", with qxl make spice very good also to use it from thin client instead of rdp and with also vdagent and usbredirection is really better (some users exchange it for a phisical pc^^)
Xen with spice full working on both windows and linux (including save/restore) used for both vkvm and thin client I think would be perfect.

> soundhw="hda"
> localtime=1
> usbversion=2
> winpv installed now and on latest tests:
> http://fantu.info/xen/winpv-20141020-free.7z
> tried also different versions of james harper's pv with same result
> and spice guest tools 0.74 (for vdagent and qxl driver)
> >
> >>After restore connecting with spice client domU "freeze" for 2-3 minutes, no
> >>errors or warnings visible in logs, I tried many times to take more
> >>informations about the problem and I already posted about it but for now
> >>nothing :(
> >>The only probably useful data are that domU's qemu process when the problem
> >>happen seems still working but domU's timing (from xl list) not increase.
> >>After restore seems do also other strange thing, "freeze" for 2-3 minutes
> >>also on windows poweroff.
> >That sounds like a timing issue. As in something is waiting for something
> >and we are not triggering it.
> >
> >>Another qxl problem is with linux domUs, I tried to find useful data to
> >>solves it for years, I also did many posts about it in xen-devel- qemu-devel
> >>and spice-devel.
> >>On latest tests domU crash (not qemu crash, I already tried qemu backtrace
> >>but seems impossible) on domU's xorg start (with qxl driver installed) and
> >>I'm unable to take useful informations in logs and various debugs tried.
> >OK, so Linux is not working at all then?
> Before "x86_emulate: properly do IP updates and other side effects on
> success" patch always black screen and xorg at 100% cpu.
> After that commit domU crash after xorg start with qxl driver installed and
> I'm unable to take backtrace or useful data about it.

OK, looking at how the driver is setup - it seems that there is an QXL
KMS driver. If you boot without Xorg running but just with in the console can
you use 'fbset' or any other framebuffer tools (linux-fb-tools)?
That is I am curious to see whether the 'FB' is working properly first
before figuring out whether Xorg is working.

Some tests ago I tried without xorg to see if kernel parts is ok (advice of other developer) and seems was ok.
I not tried it on latest test.

Thanks for any reply and sorry for my bad english.

Xen-devel mailing list

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.