[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [BUG] Only 1 VCPU is detected in Xen 4.1 - "A valid RSDP was not found"

  • To: xen-devel@xxxxxxxxxxxxx
  • From: John Mok <a9121431@xxxxxxxxx>
  • Date: Tue, 22 Jul 2014 17:04:34 +0800
  • Delivery-date: Tue, 22 Jul 2014 09:04:41 +0000
  • List-id: Xen developer discussion <xen-devel.lists.xen.org>

Hi Andrew,

Thank you for your prompt reply.

>Can you post all of xm dmesg rather than just a snippet?

The full xm dmesg and dmesg logs are enclosed in this message.

>Is this a legacy boot or an EFI boot?

It is an EFI boot, because EFI + GPT is needed to manage the disk storage > 2TB.

I tried Xen 4.4 with kernel 3.13 in Ubuntu 14.04 (and Xen 4.1 with
kernel 3.11 in Ubuntu 12.04), but the USB keyboard / mouse failed to
work in both cases. Thus, I fall back to Debian Wheezy Xen 4.1.

Thanks a lot.

John Mok

On Tue, Jul 22, 2014 at 3:50 PM, Andrew Cooper
<andrew.cooper3@xxxxxxxxxx> wrote:
> On 22/07/2014 05:54, John Mok wrote:
>> Hi,
>> I tried to install Xen 4.1 using new Intel Atom C2758, which has 8
>> cores and VT-x feature. However, only 1 CPU was available in Dom0 and
>> SMP disabled.
>> When booted to normal kernel 3.2 without Xen, all 8 cores were available.
>> Thanks a lot.
>> John Mok
>> (the acpi dump is also attached)
>> === Begin of xm dmesg ===
>> (XEN) ACPI Error (tbxfroot-0220): A valid RSDP was not found [20070126]
>> (XEN) System RAM: 32759MB (33545412kB)
>> (XEN) Domain heap initialised
>> (XEN) Table is not found!
>> (XEN) Enabling APIC mode:  Flat.  Using 1 I/O APICs
>> (XEN) SMP mptable: no processors registered!
>> (XEN) BIOS bug, MP table errors detected!...
>> (XEN) ... disabling SMP support. (tell your hw vendor)
>> (XEN) Found and enabled local APIC!
>> === End of xm dmesg ===
> Xen only has a single CPU because it can't find the ACPI tables, and the
> MP table lists no secondary processors.  By default, dom0 has the same
> number of vcpus as Xen has pcpus.
> Can you post all of xm dmesg rather than just a snippet?
> Is this a legacy boot or an EFI boot?
> Are you able to try a more up-to-date version of Xen?  4.1 is quite old now.
> ~Andrew

Attachment: dom0.log
Description: Binary data

Attachment: hypervisor.log
Description: Binary data

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.