[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] åå: Re: QXL problem: Xen 4.4.1 rc1 and xen 4.5 unstable

Hi Fabio Fantoni,
     Thank you for your advice for building xen unstable.
     Because I have to use debian wheezy as production distro, I've got to do the test in it.
     Today, I edit Config.mk and write:
QEMU_UPSTREAM_URL = git://git.qemu.org/qemu.git
     Then, the built qemu-xen binary works well.  Therefore, I guess that git://xenbits.xen.org/qemu-upstream-unstable.git  has some very little difference
compared to qemu.git. Maybe your environment cannot repeat  that problem either, I'd like to provide any useful information to resolve this problem.

Best Regards

Date: 2014-07-15 16:09
Subject: Re: [Xen-devel] QXL problem: Xen 4.4.1 rc1 and xen 4.5 unstable
Il 15/07/2014 07:53, kevin.zhang@xxxxxxxxxxx ha scritto:
Hi Fabio Fantoni,
      Today I tried to use wheezy backports version of spice-server, the problem persists with qemu-xen binary, while my self compiled qemu 2.0 works well.
I think it is a problem and can be repeated.
     Then, I will summarize my compilation process here:
     Firstly install debian wheezy 7.5 amd64 and necessary build dependency. Then:
2.  install backport version  libspice-server-dev libspice-protocol-dev
root@debian:~#  apt-cache policy libspice-server-dev libspice-protocol-dev
  Installed: 0.12.4-0nocelt2~bpo70+1
  Candidate: 0.12.4-0nocelt2~bpo70+1
  Version table:
*** 0.12.4-0nocelt2~bpo70+1 0
        100 http://cdn.debian.net/debian/ wheezy-backports/main amd64 Packages
        100 /var/lib/dpkg/status
  Installed: 0.12.6-1~bpo70+2
  Candidate: 0.12.6-1~bpo70+2
  Version table:
*** 0.12.6-1~bpo70+2 0
        100 http://cdn.debian.net/debian/ wheezy-backports/main amd64 Packages
        100 /var/lib/dpkg/status
 3. patch for QXL option
 4. ./configure --prefix=/usr 
 5. add spice and usb-redir option for qemu-xen-upstream
 6. make xen;make tools;make install-xen;make install-tools
       To compile qemu 2.0 from qemu.org:
       2. ./configure --enable-xen --target-list=i386-softmmu --extra-cflags="-I/usr/src/xen/tools/include -I/usr/src/xen/tools/libxc -I/usr/src/xen/tools/xenstore" \
            --enable-spice --enable-usb-redir
       3 .make;make install

For fast unstable tests I do this (using my github rebase/m2r-*):
Install of opus, usbredir and libusbx from backports.
Rebuild and install new seabios 1.7.5-1 and spice packages (server 0.12.5-1 and protocol
0.12.7-1) from sid that contains many fixes (simply and fast with git clone of debian repository and debuild).
./configure --prefix=/usr --enable-qemu-traditional=no --with-system-seabios=/usr/share/seabios/bios-256k.bin --with-extra-qemuu-configure-args="--enable-spice --enable-usb-redir"
make debball
dpkg -i of xen package in dist (contain both xen and qemu)
And if I need to test newer qemu in development I simply change the qemu git with mainline in Config.mk.

And for newer production servers I start prepared new xen's debian packages awaiting debian maintainers replies:
Needs also qemu rebuild to use new xen 4.4 libraries (simply and fast with git clone of debian repository and debuild).

There is also a problem of jpeg-turbo in debian and for have better performances and not too many cpu waste I for now solved with:
apt-key adv --recv-keys --keyserver keys.gnupg.net E1F958385BFE2B6E
vi /etc/apt/sources.list.d/x2go.list
# X2Go Repository (for jpeg-turbo as default and with full -dev package)
deb http://packages.x2go.org/debian wheezy heuler
deb-src http://packages.x2go.org/debian wheezy heuler
aptitude update
aptitude install x2go-keyring && aptitude update
aptitude install libjpeg8-turbo-dev


Best Regards

åéæéï 2014-07-14 16:49
äéï åå: Re: [Xen-devel] QXL problem: Xen 4.4.1 rc1 and xen 4.5 unstable
Hi Fabio Fantoni,
      Thank you for your reply.
      It is really weird.
      I compiled both qemu binary ( qemu-upstream in xen and qemu-2.0 from qemu.org website) in the same environment,  the binary in xen has the problem while
the other one works well.
      I will check whether wheezy backport has libspice-server-dev and libspice-protocol-dev and try again. 

Best Regards

Date: 2014-07-14 15:59
Subject: Re: [Xen-devel] QXL problem: Xen 4.4.1 rc1 and xen 4.5 unstable
Il 14/07/2014 07:29, kevin.zhang@xxxxxxxxxxx ha scritto:
Hi Fabio Fantoni,
     Today, I've done another test on xenbits xen 4.5 unstable.
     This time, I directly compiled xen on my test server, and use default libspice-server-dev  and libspice-protocol-dev header files for spice option.
root@debian:~# apt-cache policy libspice-server-dev libspice-protocol-dev
  Installed: 0.11.0-1+deb7u1
  Candidate: 0.11.0-1+deb7u1
  Version table:
*** 0.11.0-1+deb7u1 0
        500 http://cdn.debian.net/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status
  Installed: 0.10.1-1
  Candidate: 0.10.1-1
  Version table:
*** 0.10.1-1 0
        500 http://cdn.debian.net/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status
     I also download qemu-2.0 source code from qemu.org, and compiled it by the way mentioned in http://wiki.xen.org/wiki/QEMU_Upstream.
     Then I create win7 hvm with qemu-xen and /usr/local/bin/qemu-system-i386 respectively.
     The result shows that:
      1 . qemu-upstream used in xen 4.5 unstable still exited when changing screen resolution,
      2.  my self-compiled qemu2.0 behave normally.
     I think maybe there's still some differences between the two qemu repository.

Use spice from backports or recompile the latest from Sid, wheezy packages are too old for newer qemu.
xen already download and compile qemu upstream automatically if you not specify binary in repository.
I also use use wheezy dom0 with same xen and qemu and same domU and spice guest tools installed automatically resize the windows resolution without problem (except rare cases when I connect remote-viewer before windows start).

Below also reply to other mail.

     I'm actively waiting for your advice and willing to do the following debug.
     vm config file is as follow:

videoram=128 is not needed with qxl as already the default.
Try to disable vnc when you use spice, even if I used with also vnc many times without problem time ago.


Best Regards

Date: 2014-07-14 10:26
Subject: Re: [Xen-devel] QXL problem: Xen 4.4.1 rc1 and xen 4.5 unstable
Hi Fabio Fantoni,
    Thank you for your help.
     If I use your method to run qemu-gdb when using xl create, xl will complain startup timeout.

I know, I already posted the solution but I try to explain better.

# after xl create with (qemu gdb), do it fast after xl create when arrive on qemu process launch (before timeout or xl create will fails)
target remote localhost:1234 # prepare this command in other ssh to the xen dom0 and enter on xl create when arrive on qemu launch
c # press immediatly
bt full # when qemu stops

Sorry for my bad english.

    Perhaps I did not describe my problem clearly enough, I can successfully create windows HVM, my problem happened when I change windows screen resolution.
The qemu process suddenly  exited while xl list can still list the domU information.
    I am using debian wheezy 7.5 amd 64, I am using fantu's xen 4.5 unstable and the qemu-xen-remote in his code repository,
root@debian:~# /usr/lib/xen/bin/qemu-system-i386 -version
QEMU emulator version 2.0.0, Copyright (c) 2003-2008 Fabrice Bellard  
 And I compiled Xen from fantu's xen repository in compilation server, then use install.sh in dist dir to install xen packages in my test server.
 My compilation server has spice 0.12.4 compiled and installed.
 My test server has debian wheezy backport qemu installed with spice-server:
dpkg -l |grep spice
ii  libspice-server1:amd64             0.12.4-0nocelt2~bpo70+1   
 Then how can I obtain useful debug information after qemu exit with vm running?

Best Regards

Date: 2014-07-11 18:06
Subject: Re: [Xen-devel] QXL problem: Xen 4.4.1 rc1 and xen 4.5 unstable
Il 11/07/2014 04:38, kevin.zhang@xxxxxxxxxxx ha scritto:
Hi all,
Firstly please forgive me if I put this problem in the wrong mail list.
However, it seems that xen-users mail list cannot resolve this QXL problems. Therefore, I have to post QXL problem in devel mail list.
My problem is as follow:
I'm testing QXL for windows HVM, spice works well with stdvga.
However, when I switch to QXL, qemu exit abnormally:
I specify vga="qxl" and videoram=128, using qemu-xen. The windows 7 boots and automatially switch resolution for me in virt-viewer.
While display and sound transfering very well, if I change display resolution, the virt-viewer will be suddenly closed and
I check the physical server, the qemu process disappear simultaneously.
Then I switch to wheezy backport qemu 2.0 as device model, the qemu process will exit as soon as the welcome page appears and at the beginning of resolution change.
I tested and found the same bug on both xenbits xen 4.4.1 rc1 and Fantu's Xen 4.5 unstable, this problem exists in both branches.
Is it a known issue or is there any solution for this bug?
Thank you very much!

Thanks for testing spice and qxl and report issue.
I have spice + qxl working as kvm on xen unstable except this problem:

Please post details on your dom0 installation and domU (for example xl cfg,
spice guest tools version ecc...)
About qemu crash try to take a full backtrace with gdb and post it here.

Small help with gdb of qemu launched by xl:

Add the line below in domU's xl cfg:

vi /usr/lib/xen/bin/qemu-gdb # create the file, change the qemu path if
exec gdbserver /usr/lib/xen/bin/qemu-system-i386 "$@"

# after xl create, do it fast (before timeout or xl create will fails)
target remote localhost:1234
bt full # when qemu stops

You should install also all needed dbg packages before, spice qemu ecc or
without package should be compiled with debug enabled (for xen and qemu
default in unstable).

The latest qemu crash with spice I saw was in 2.0-rc solved before 2.0.0
final, your qemu is at least 2.0.0 final?

Best Regards,


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.