[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [RFC PATCH v2 6/7] Changed slice to budget in libxc for the sedf scheduler

On ven, 2014-07-11 at 12:11 +0100, Ian Campbell wrote:
> On Fri, 2014-07-11 at 01:11 +0200, Dario Faggioli wrote:

> > 'budget' is certainly the most used term in real-time literature and
> > research, yes, but slice is not that terrible after all. I think it does
> > get the point across about how one should interpret and use the
> > parameter itself.
> > 
> > If we were doing a new scheduler, I think I also would pick budget as
> > the name for this param. If we are to modify SEDF, I honestly think we
> > can live with 'slice'.
> Have the semantics changed though? If yes then a new name is preferable.
They're basically synonyms, and the new algorithm uses this budget
exactly as current SEDF use slice, no semantic change.

And in fact this patch basically is s/slice/budget/g all over the file.

Budget is more widely used and recognized in the real-time literature,
but that's it.


<<This happens because I choose it to happen!>> (Raistlin Majere)
Dario Faggioli, Ph.D, http://about.me/dario.faggioli
Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)

Attachment: signature.asc
Description: This is a digitally signed message part

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.