[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Bug: /proc/xen Doesn't Mount

On mar, 2014-06-17 at 10:09 -0700, merc1984@xxxxxx wrote:
> > You are not running 'xenstored' or 'oxenstored'. Your init scripts
> > should have run that - did you made sure they were setup in the
> > right
> > init level?
> I don't know what is or isn't supposed to be started or when.  (No
> documentation)  To be honest I was surprised when the install actually
> set up grub to add the hypervisor boot, but nothing else has been
> done.  In fact it actually -deleted- my <domain>.cfg files which I've
> worked for weeks on.  I've tried to recostruct them from notes.  But I
> can't start them now.
> There is no 'xenstored' or 'oxenstored' in /etc/init.d.  The only
> scripts there are xen, xencommons, xendomains, and xen-watchdog.  Of
> those, the only ones enabled are xen and xendomains.  This is the
> xen-4.4.0 source.
xencommons is the one you want.

So `# /etc/init.d/xencommons start' to try, and then make that permanent
the way your distro prefers.
> I tried putting all the modules which are in xencommons,
> into /etc/initramfs-tools/modules, update-ramfs -u, and rebooting, but
> no change.
Making sure that xencommons starts on boot should be enough.


<<This happens because I choose it to happen!>> (Raistlin Majere)
Dario Faggioli, Ph.D, http://about.me/dario.faggioli
Senior Software Engineer, Citrix Systems R&D Ltd., Cambridge (UK)

Attachment: signature.asc
Description: This is a digitally signed message part

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.