[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] dom0 USB failing with "ehci-pci: probe of 0000:00:1d.0 faile

Mike Egglestone writes:
Did that, rebooted and still no keyboard.

FWIW, I pulled the drive out and slapped it into a Dell Optiplex 7010 I have as a spare
workstation, booted it and keyboard works.

Further to this, I went back to stock everything.
3.13 kernel with debian's xen 4.3.0.
Moved the internal USB connector to the other port on the motherboard.
(This wire connects the 2 front USB connectors on the front panel of the chassis)
and rebooted with the USB keyboard plugged into the front panel.

Keyboard works!

Moved the keyboard back to any of the 4 rear onboard USB ports, and keyboard does not work.
Either of the 2 front side USB ports worked.

Downed the server, moved the internal USB connector back to the first USB slot it was
plugged into originally, plugged the keyboard into one of the 2 front panel usb ports and booted it up.
Keyboard does not work.

Keyboard works in all cases and ports at the grub prompt. (unless bios usb legacy is disabled)

This is so strange.

I found a server with an Intel S2600CP board in it, slapped the drive into that and booted
into xen, keyboard works. (plugged into rear onboard usb ports)

Either it's this particular model of Intel board(S1200BTL), or just this one board that I have.
If I can find another S1200BTL board, I will try it, but I'm happy to close this bug and
just blame the board, the BMC or the C204 chipset.


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.