[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH v4 8/8] ioreq-server: bring the PCI hotplug controller implementation into Xen
>>> On 02.04.14 at 17:11, <paul.durrant@xxxxxxxxxx> wrote: > +static int handle_gpe_io( > + int dir, uint32_t port, uint32_t bytes, uint32_t *val) > +{ > + struct vcpu *v = current; > + struct domain *d = v->domain; > + struct hvm_hotplug *hp = &d->arch.hvm_domain.hotplug; > + > + if ( bytes != 1 ) Is this really a valid restriction? > +int gpe_init(struct domain *d) > +{ > + struct hvm_hotplug *hp = &d->arch.hvm_domain.hotplug; > + > + hp->gpe_sts = xzalloc_array(uint8_t, ACPI_GPE0_BLK_LEN_V1 / 2); > + if ( hp->gpe_sts == NULL ) > + goto fail1; > + > + hp->gpe_en = xzalloc_array(uint8_t, ACPI_GPE0_BLK_LEN_V1 / 2); > + if ( hp->gpe_en == NULL ) > + goto fail2; I'd like to ask (also elsewhere in this series) to try to limit the number of "goto"s to the absolute minimum required to help code readability. There's no need for them here: Allocate both blocks, then check both pointers, and if either is NULL free them both in a single error path. Jan _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |