[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [RFC PATCH 4/5] xen/pciback: Move the FLR code to a function.
>>> On 13.12.13 at 17:09, Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx> wrote: > +void pcistub_reset_pci_dev(struct pci_dev *dev) > +{ > + /* This is OK - we are running from workqueue context > + * and want to inhibit the user from fiddling with 'reset' > + */ > + > + dev_dbg(&dev->dev, "resetting (FLR, D3, etc) the device\n"); > + > + pci_reset_function(dev); > + pci_restore_state(dev); > + > + /* This disables the device. */ > + xen_pcibk_reset_device(dev); > + > + /* And cleanup up our emulated fields. */ > + xen_pcibk_config_reset_dev(dev); > +} Ah, here it comes. Improperly split series then... Jan _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |