[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 08/18] PVH xen: tools changes to create PVH domain

On 30/08/13 02:24, Mukesh Rathor wrote:
On Thu, 29 Aug 2013 12:29:44 +0100
Ian Campbell <Ian.Campbell@xxxxxxxxxx> wrote:

On Thu, 2013-08-29 at 12:13 +0100, George Dunlap wrote:
On Thu, Aug 1, 2013 at 3:02 AM, Mukesh Rathor
<mukesh.rathor@xxxxxxxxxx> wrote:
I'm not sure how you are currently signalling to the hypervisor
that a new domain is a PVH domain? I had a look through this
patch and must be being thick because I don't see it.
I had a flag set, but it was recommended during RFC to remove it.
So, now in xen, a PV with HAP is a PVH guest:
Why was it recommended to remove it?

"PVH == PV + HAP" is a ridiculous interface, and one which will make
it hard to import shadow in the future.  In my series I'm planning
on adding XEN_DOMCTL_CDF_pvh_guest, and using that instead.
These are not stable ABI interfaces, so if someone wants to do PVH
with Shadow then they can just change it.
I thought we named PVH for PV with HAP :).. for shadow are we going
to rename it to PVS?? :)..... Besides for shadow the tools do the right

     if ( xc_dom_feature_translated(dom) && !dom->pvh_enabled )
         dom->shadow_enabled = 1;
         rc = x86_shadow(dom->xch, dom->guest_domid);

In any case, I am ok either way...

But you said "it was recommended to remove it". Who recommended removing it and why?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.