[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] HVM hangs system on AMD A10-6800K + Hudson-D4

On Wed, Aug 14, 2013 at 11:22 AM, Hurwitz, Sherry <sherry.hurwitz@xxxxxxx> wrote:

I would like to help you because my team at AMD does not see this problem but maybe there is something unique in your environment that we have not tested with.  So you are using the Xen hypervisor from XenServer 6.2 and you have tested with Centos and Unbuntu guests?  Could you tell me your Guest configurations (vcpus and memory per guest).  Any information you can provide would be appreciated.


I found another user on the xen-users list who experienced this same problem [1] with the same APU but with a different motherboard that has a Hudson-D3.  He suggested compiling and running Xen from the latest source and that seemed to work.  I haven't extensively tested this, but before the system would freeze under a minute and now I've ran it for a couple hours with no issues.  So I have ran all of the following dom0 setups and they have failed:

XenServer 6.2
CentOS 6.4
Ubuntu 13.04
Ubuntu 13.04 + Xen 4.3 compiled from source

So there is something that was checked in since Xen 4.3 that seems to fix the issue or did something to mask the issue.  Specifically what I was doing that made it fail was that I was running a Windows XP installation from ISO.  During the installation, around the time of entering your product key or configuring networking the system would hang.  On XenServer the domain was configured just however XenServer does it when selecting the OS type as Windows XP.  On CentOS and Ubuntu I was using the smallest xl cfg I could which was basically name, builder, disks, vif, memory.

I started debugging the issue further on Ubuntu 13.04 and got it so that I can easily reproduce it.  I'm running basically a fresh install of 13.04 64-bit with "apt-get install xen-hypervisor-4.2."  I then disabled all features I could in the BIOS to just start ruling things out.  So I turned off SMP, IOMMU, CPB, NX, C6, and PowerNow!.  All other settings in the BIOS are default.  If I ran the following xl conf

name = 'blank'
builder = 'hvm'
memory = 1024

I then run "xl create -f blank.cfg" so that domain creates, and then about a second later I run "xl create -f blank.cfg 'name="blank2"'"  Its about 50/50 if the system freezes on the first "xl create" or the second.  So basically, I can reproduce the issue with no domU OS.

Unfortunately I don't have a COM port plugged into the motherboard and I haven't had time to go run and buy a com port to plug into the motherboard so I have no clue if Xen is logging any errors, but I definitly don't get anything on the linux console or in logs.  Below are the specs of the system I have

AMD A10-6800K
G.SKILL Ripjaws X Series 32GB (4 x 8GB) DDR3 2400 <-- Running at 1333mhz (which is BIOS default)

I'm particularly interested in what has made this work in latest git because I'd like the patch to be backed ported into Xen 4.2.x so that CentOS can pick it up.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.