[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [Qemu-devel] Test report for xen-unstable and qemu-xen

Il 14/08/2013 01:58, Kevin O'Connor ha scritto:
On Tue, Aug 13, 2013 at 03:26:43PM +0200, Fabio Fantoni wrote:
Il 13/08/2013 13:09, Laszlo Ersek ha scritto:
On 08/13/13 12:33, Fabio Fantoni wrote:
Il 13/08/2013 12:04, Laszlo Ersek ha scritto:
On 08/13/13 11:16, Fabio Fantoni wrote:
Il 12/08/2013 17:04, Fabio Fantoni ha scritto:
New issue:
- domU not start with qemu 1.5.1 and more that 2 gb of ram:
    tested on w7 64 bit domU with 4 gb of ram, with built-in qemu 1.3 it
    while with qemu 1.5.1 doesn't (stops at the beginning, spice client
show only the lines of seabios version and machine UUID;
    qemu log show nothing more that 2 gb test), while with 2 gb of ram
works also with qemu 1.5.1
I did another test disabling the usb controller: it didn't find any
bootable disk and tried to boot with pxe. I also tried F12 and it
reported an hard-disk size of 0 MB.
Configuration is correct because if I change the ram size to 2 GB
instead of 4, it starts correctly.
No additional information from qemu log.
I tried also seabios and master from git, both with same result.
It's not clear to me if this is a QEMU issue or SeaBIOS issue.  Can
you arrange to run qemu with the following added to the command line:

-chardev stdio,id=seabios -device isa-debugcon,iobase=0x402,chardev=seabios

and post the full log from a successful (2G) boot as well as the
unsuccessful (4G) boot?


Tried qemu 1.6.0-rc3, hvm domU does not start in any case because qemu crashes on start

xl create /etc/xen/W7.cfg
Parsing config from /etc/xen/W7.cfg
  Loader:        0000000000100000->000000000019ee88
  Modules:       0000000000000000->0000000000000000
  TOTAL:         0000000000000000->000000007f000000
  ENTRY ADDRESS: 0000000000100000
  4KB PAGES: 0x0000000000000200
  2MB PAGES: 0x00000000000003f7
  1GB PAGES: 0x0000000000000000
libxl: error: libxl_dm.c:1313:device_model_spawn_outcome: domain 1 device model: spawn failed (rc=-3) libxl: error: libxl_create.c:1079:domcreate_devmodel_started: device model did not start: -3 libxl: error: libxl_dm.c:1344:libxl__destroy_device_model: Device Model already exited

xc: error: linux_gnttab_set_max_grants: ioctl SET_MAX_GRANTS failed (22 = Invalid argument): Internal error
xen be: qdisk-768: xc_gnttab_set_max_grants failed: Invalid argument
xc: error: linux_gnttab_set_max_grants: ioctl SET_MAX_GRANTS failed (22 = Invalid argument): Internal error
xen be: qdisk-832: xc_gnttab_set_max_grants failed: Invalid argument

Tried with qemu 1.4.2 and it works also with 4 gb of ram.
This ram regression seems to be introduced with qemu 1.5, and there is another regression more critical with qemu 1.6.

Tried to add seabios debug options to domU xl configuration file...

device_model_args=["-chardev stdio,id=seabios","-device","isa-debugcon,iobase=0x402,chardev=seabios"]

But it doesn't boot

qemu-system-x86_64: -chardev stdio,id=seabios: invalid option

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.