[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Testing xen-arm on Arndale

I somehow end-up running "xl list" in dom0 and it gives the following results:

    root@localhost:/root/make_test# xl list
    Name                                        ID   Mem VCPUs    State    Time(s)
    (null)                                       0   256     1     r-----    8071.1

Looks like the root file system in the above link is just fine :-)
Just have to enable all xen-related features while building linux (e.g., xen-driver-support and xen-network-device-frontend-driver).

Now I am going to run DomU and have a question regarding the following wiki (DomU kernel and DTS section):

(Question) In the configuration file, there is a line:
        kernel = "/root/kernel"
I think this one is pointing to some kernel image used for booting and how can I build this image? (for instance, can I use the same kernel source for dom0?)

Also, is there a helpful wiki link that describes manually building domU image?


On Wed, Mar 27, 2013 at 5:23 PM, Sengul Thomas <thomas.sengul@xxxxxxxxx> wrote:
I'm using the root file system from "http://snapshots.linaro.org/quantal/images/server/" and it lacks a lot of stuffs for running domU.

Are you also using RFS above or another one?

Also, if you have a working RFS that can launch domU, could you post it on wiki?

Thanks always,

On Wed, Mar 27, 2013 at 4:29 AM, Julien Grall <julien.grall@xxxxxxxxxx> wrote:
On 03/26/2013 04:04 PM, Anthony PERARD wrote:

> CC'ing xen-devel, where the ARMv7+ port of Xen is happening.
> On 25/03/13 09:46, Sengul Thomas wrote:
>> Hello Anthony,
>> I'm hoping your are the right person to ask about xen-arm on Arndale.
>> I've tried the following wiki to run xen-arm on Arndale and it crashes while booting dom0.
>> http://wiki.xen.org/wiki/Xen_ARM_with_Virtualization_Extensions/Arndale
>> Here goes some part of log (attached the full log):
>> (XEN) Guest data abort: Translation fault at level 2
>> (XEN)     gva=23c1901c
>> (XEN)     gpa=0000000023c1901c
>> (XEN)     size=2 sign=0 write=1 reg=0
>> (XEN)     eat=0 cm=0 s1ptw=0 dfsc=6
>> (XEN) dom0 IPA 0x0000000023c1901c
>> (XEN) P2M @ 02ffbfc0 mfn:0xbfdfe
>> (XEN) 1ST[0x0] = 0x00000000bfdfd6ff
>> (XEN) 2ND[0x11e] = 0x0000000000000000
>> (XEN) ----[ Xen-4.3-unstable  arm32  debug=y  Tainted:    C ]----
>> (XEN) CPU:    0
>> (XEN) PC:     4000893c
>> Looks like dom0 tried to access at 23c1901c and page fault happens.
>> I've got no idea how to figure out what is going on.
>> Could you tell me any helpful tips to move on further?

It's seems the kernel is unable to start when the zImage is loaded at
0x40007000. If you change this address, both in U-Boot and the DTS, by
0x60000000 the kernel is able to start.

I updated wiki page with the new instructions and the new device tree.



Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.