[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Testing xen-arm on Arndale

CC'ing xen-devel, where the ARMv7+ port of Xen is happening.

On 25/03/13 09:46, Sengul Thomas wrote:
> Hello Anthony,
> I'm hoping your are the right person to ask about xen-arm on Arndale.
> I've tried the following wiki to run xen-arm on Arndale and it crashes while 
> booting dom0.
> http://wiki.xen.org/wiki/Xen_ARM_with_Virtualization_Extensions/Arndale
> Here goes some part of log (attached the full log):
> (XEN) Guest data abort: Translation fault at level 2
> (XEN)     gva=23c1901c
> (XEN)     gpa=0000000023c1901c
> (XEN)     size=2 sign=0 write=1 reg=0
> (XEN)     eat=0 cm=0 s1ptw=0 dfsc=6
> (XEN) dom0 IPA 0x0000000023c1901c
> (XEN) P2M @ 02ffbfc0 mfn:0xbfdfe
> (XEN) 1ST[0x0] = 0x00000000bfdfd6ff
> (XEN) 2ND[0x11e] = 0x0000000000000000
> (XEN) ----[ Xen-4.3-unstable  arm32  debug=y  Tainted:    C ]----
> (XEN) CPU:    0
> (XEN) PC:     4000893c
> Looks like dom0 tried to access at 23c1901c and page fault happens.
> I've got no idea how to figure out what is going on.
> Could you tell me any helpful tips to move on further?

Sorry, I don't know where this address come from. So, let's look at what
Linux is doing.

> One more question:
> How can I look up the function that PC is pointing (4000893c)?

There is a programme called `addr2line` and you can use it like that:
$ addr2line -e vmlinux 4000893c
and it will give a source file and hopefully a line.

Then, if this does not help, there is always objdump to disassemble and
get addresses associated with instructions and function names.
So I do `arm-unknown-linux-gnueabi-objdump -d vmlinux | less`  and
search for the PC.

There is 2 vmlinux, one (linux.git/arch/arm/boot/compressed/vmlinux)
that decompress the second one (linux.git/vmlinux).


Anthony PERARD

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.