[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] RFC: xl and HVM usb devices

On Tue, 2013-03-12 at 14:29 +0000, George Dunlap wrote:

> * How important is it to do both qemu-xen and qemu-traditional?

IMHO it is fine for new features to be implemented for qemu-xen only.

Even in the case where we are adding an xl feature which was already in
implemented in xm then I think it is OK for qemu-xen to come first with
qemu-trad either following later or even not at all in some cases.

> * Do we use the old-style device specification for usb-add and usb-del
> on the xl command-line, and translate it into qdev?  Or try to come up
> with something closer to the qdev model (and back-translate it to the
> old model if we are doing something for qemu-traditional)?

Closer to the qdev model would seem like the better idea going forward.

One thing we could consider is grandfathering in specific old-style
names which are widely used and supporting those as a kind of hack on
the side, sort of like how we made the disk spec backwards compatible
while also rationalising it.

> * If we try to do something for 4.3, should we just do usb-add?  Or
> usb-add and usb-del?  Or try to implement usb-add, usb-del, and
> usb-list?

I think it would be better to aim for basic parity with the xm
functionality (limited as it is) rather than to aim further and miss.

> * What kind of naming convention should we use? Using "hvm_usb_add"
> and "pv_usb_add" comes to mind; I'm not entirely satisfied with that,
> but other options seem less appealing.

These are naming conventions for which API, libxl, xl command line?
Something else?

> I'm sort of wavering between just about all of these options, so any
> input would be welcome. :-)
>  -George

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.