[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] pv guest fails to boot after 4.2 upgrade

On Sat, 2013-01-05 at 01:42 +0000, Travis Osterman wrote:
> I hope this is the appropriate list.  If not, I apologize.

xen-users@ is usually more appropriate for support in the first

>   I'm new to 
> xen and have been able to get xen (and xen-tools) 4.1 installed on my 
> gentoo system running 3.7 hardened kernel without issue. After unmasking 
> and installing xen 4.2, I get the following error when I attempt to boot 
> a pv guest that worked fine in 4.1 (no configuration changes ... after 
> reboot).  I've tried to see if there was a new configuration requirement 
> that I'm missing by reading the 4.2 release notes.  So far I haven't had 
> any luck.  Thank you in advance for any help.
> -- Travis Osterman
> # xl create -c /data/xen/config/try2.pv
> Parsing config from /data/xen/config/try2.pv
> libxl: error: libxl_dm.c:1212:device_model_spawn_outcome: domain 2 
> device model: spawn failed (rc=-3)
> libxl: error: libxl_qmp.c:641:libxl__qmp_initialize: Connection error: 
> No such file or directory

Did your ebuild include the new qemu-upstream stuff? It seems like they
might be missing. "xl -vvv create ..." should give some more

Xen 4.2 switched from the old qemu-xen-traditional fork of qemu to the
upstream qemu based qemu-xen by default to supply disks to disk backends
to PV guests (trad remains the default for HVM guests).


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.