[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH V2 3/5] exec: Introduce helper to set dirty flags.
On 07/20/2012 05:34 PM, Anthony PERARD wrote: > This new helper/hook is used in the next patch to add an extra call in a > single > place. > > Signed-off-by: Anthony PERARD <anthony.perard@xxxxxxxxxx> > --- > exec.c | 42 ++++++++++++++---------------------------- > 1 files changed, 14 insertions(+), 28 deletions(-) > > diff --git a/exec.c b/exec.c > index feb4795..b24a03a 100644 > --- a/exec.c > +++ b/exec.c > @@ -3386,6 +3386,16 @@ int cpu_memory_rw_debug(CPUArchState *env, > target_ulong addr, > } > > #else <blank line> > +static void set_dirty_helper(target_phys_addr_t addr, target_phys_addr_t > length) More meaningful name please. Practically every function can be name something_helper(). > +{ > + if (!cpu_physical_memory_is_dirty(addr)) { > + /* invalidate code */ > + tb_invalidate_phys_page_range(addr, addr + length, 0); > + /* set dirty bit */ > + cpu_physical_memory_set_dirty_flags(addr, (0xff & ~CODE_DIRTY_FLAG)); > + } > +} > + Otherwise looks good; a nice cleanup in its own right. -- error compiling committee.c: too many arguments to function _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxx http://lists.xen.org/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |