[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] Fedora Core 17 Xorg can't use /dev/fb0 when using Cirrus Logic VGA or Xen PVFB driver, Was:Re: irq problem with 3.3-rc3 on guest

On Tue, Mar 27, 2012 at 11:14:30PM +0100, M A Young wrote:
> On Mon, 26 Mar 2012, Konrad Rzeszutek Wilk wrote:
> >So how are you actually trying to install F17?
> >I tried:
> >virt-install --name F17 --ram 1024 --disk /dev/vg_guest/f17_32 --paravirt 
> >--location http://build/tftpboot/f17-i386/
> >
> >and it showed the text console, and then rebooted thinking it was complete.
> >When using a manual guest config:
> >kernel="/root/vmlinuz-PAE"
> >ramdisk="/root/initrd-PAE.img"
> >append="console=hvc0 loglevel=8 root=http://build/tftpboot/f17-i386";
> >memory=1024
> >maxvcpus = 2
> >vcpus = 2
> >disk = ['phy:/dev/vg_guest/f17_32,xvda,w']
> >vif = [ 'type=netfront, bridge=switch' ]
> >vfb = [ 'vnc=1, vnclisten= ,vncunused=1']
> >
> >I get this:
> > 5.680395] Broadcom NetXtreme II iSCSI Driver bnx2i v2.7.0.3 (Jun 15, 2011)
> >[    5.681923] iscsi: registered transport (bnx2i)
> >[    5.696419] iscsi: registered transport (be2iscsi)
> >[    5.763271] dracut: FATAL: No or empty root= argument
> >[    5.764158] dracut: Refusing to continue
> >[    5.769524] dracut Warning: Signal caught!
> >[    5.772973] dracut Warning: dracut: FATAL: No or empty root= argument
> >[    5.776138] dracut Warning: dracut: Refusing to continue
> >[    5.782548] init used greatest stack depth: 5480 bytes left
> >[    5.783425] Kernel panic - not syncing: Attempted to kill init!
> >
> >so is there a new syntax for the root parameter now that is a LiveCD?
> Yes, the F17 install image is now a liveCD so you need to specify
> this on the boot command line. This may be as simple as replacing
> root= with root=live:

So with extra="console=hvc0 loglevel=8 

I was able to succesfully install, but booting proved interestingly.

When trying the 'pygrub' it would complain about the 'No OS loader', but if I 
it on the disk (pygrub /dev/vg_guest/f17_32) it would extract the payload 
(This is with xen-4.1.2-6.fc16). So I worked around by taking those images

extra="root=/dev/mapper/vg_f17-lv_root ro rd.md=0 rd.lvm.lv=vg_f17/lv_swap 
SYSFONT=True  KEYTABLE=us rd.lvm.lv=vg_f17/lv_root rd.luks=0 LANG=en_US.UTF-8 

And when booting F17 either as HVM or PV, in both cases I got Xorg to
tell me:

(EE) FBDEV(0): FBIOBLANK: Invalid argument

and freeze.

The /dev/fb0 works fine thought by itslef, if do:

"exec /sbin/init 3", then login on the VNC window and
run 'fbterm' I get an nice framebuffer terminal.

@M A: Is there a BZ for this or should I open one up with Xorg?
I would think that KVM would hit the same exact problem when using the
default VGA Cirrus framebuffer.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.