[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Panic on CPU0 : Unable to boot with Xen 4.1 on Fedora 16, manual grub2 config after compiling Xen from source

On Wed, Mar 7, 2012 at 2:34 PM, Ranjith Krishnan <pkranjithpk@xxxxxxxxx> wrote:
> Hello all,
> I had asked my question on xen-users list, but I did not get any responses
> for 5 days despite bumping the mail up once. Hence forwarding the question
> here.
> Hello,
> Newbie here. So please be patient. If you need any extra information please
> ask, and I will try to provide.
> My intention is to study xen source and hopefully make some contributions to
> it. So I tried to compile Xen 4.1 from source and start using it.

OK, but does the version that come with Fedora work for you? Have you tried
'yum install xen' and seen how it installs and configured the grub2.cfg?

> My environment details:
> 2.0 GHz 32 bit CPU, 2GB RAM with XP and Ubuntu Wubi install. ( Ubuntu
> installed as an application within XP, can dual boot)
> Trying to install Xen on external USB Hard disk (500 GB) : Installed Fedora
> 16 on this. Can boot and use Fedora 16 just fine from this.
> I found these tutorials after searching and used them.
> 1. http://wiki.xen.org/wiki/Fedora_13_Xen_4_Tutorial
> Used a partition scheme very similar to one mentioned in above tutorial.
> Also disabled selinux.

Ewww. That is not good. Please don't use that.
> 2. Found a second tutorial for building xen from source:
> http://wiki.xen.org/wiki/Compiling_Xen
> 3. I only complied and installed Xen, not linux kernel ( because wiki says
> Fedora16 kernel is a valid Xen Dom0 Kernel ) according
> to http://wiki.xen.org/wiki/Fedora_16_Dom0
> After I installed Xen, confirmed that under /boot I have xen.gz, and the
> folder /etc/xen exists.
> I modified my grub2.cfg file by looking at a sample grub2 configuration
> mentioned
> at http://old-list-archives.xen.org/archives/html/xen-changelog/2011-10/msg00151.html
> Now when I boot with Xen 4.1, it gives me a Kernel panic and fails to load
> the dom0 kernel. Exact error message is
> 'elf_xen_note_check: ERROR: Will only load images built for the generic
> loader or Linux images')

So that looks like you are trying to load the initrd image instead of
the kernel. Sounds to me that you have missed a "module" line or
perhaps are using the "kernel"/ "initrd"

I would strongly recommend you first install from the yum repos so
that you can get a working baseline first.
> PANIC on CPU0:
> Could not setup DOM0 guest OS
> I am attaching my grub configuration file. Please have a look and advice.
> --
> Ranjith
> _______________________________________________
> Xen-devel mailing list
> Xen-devel@xxxxxxxxxxxxx
> http://lists.xen.org/xen-devel

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.