[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 29 of 29 RFC] libxl: delegate plug/unplug of disk and nic devices to xldeviced

Roger Pau Monné writes ("Re: [Xen-devel] [PATCH 29 of 29 RFC] libxl: delegate 
plug/unplug of disk and nic devices to xldeviced"):
> 2012/2/9 Ian Jackson <Ian.Jackson@xxxxxxxxxxxxx>:
> > and to make the new functionality have the same
> > libxl_device_disk_add name (etc.) as before.
> I would like to keep the original libxl_device_<type>_add functions,
> since they are called from xldeviced and perform the actual plug of
> the device. libxl_device_<type>_hotplug_add are called from xl to
> trigger the plug (pass the command to xldeviced). Probably the names
> should be changed to something more descriptive of what they actually
> do, I'm open to suggestion there.

Something like that.  But if xldeviced is an internal feature of
libxl, rather than a user of libxl's public API (which is how I think
it should be) then all of these functions should be called
libxl__something and not be expored in libxl.h.

> How does renaming libxl_device_<type>_add to
> libxl_device_<type>_plug/unplug (which will be called from xldeviced)
> and libxl_device_<type>_hotplug_add to libxl_device_<type>_add, this
> will mean less modifications in xl code since it will call the same
> functions?

Yes, exactly.  I don't think this move should involve changing xl
(unless of course we discover bugs in the api...)


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.