[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 29 of 29 RFC] libxl: delegate plug/unplug of disk and nic devices to xldeviced

2012/2/9 Ian Jackson <Ian.Jackson@xxxxxxxxxxxxx>:
> Roger Pau Monne writes ("[Xen-devel] [PATCH 29 of 29 RFC] libxl: delegate 
> plug/u> libxl: delegate plug/unplug of disk and nic devices to xldeviced
>> Change the calls to libxl_device_<type>_<action> to
>> libxl_device_<type>_hotplug_<action> for disk and nic device types.
>> Alsoe enables hotplug script calling from libxl itself, by disabling
>> some udev rules and removing the commented code in
>> libxl__device_hotplug.
> Again, I don't think this is the right way to organise the change to
> this behaviour.
> The right thing to do is probably to change individual device types
> one at a type,

True, will refactor this.

> and to make the new functionality have the same
> libxl_device_disk_add name (etc.) as before.

I would like to keep the original libxl_device_<type>_add functions,
since they are called from xldeviced and perform the actual plug of
the device. libxl_device_<type>_hotplug_add are called from xl to
trigger the plug (pass the command to xldeviced). Probably the names
should be changed to something more descriptive of what they actually
do, I'm open to suggestion there.

How does renaming libxl_device_<type>_add to
libxl_device_<type>_plug/unplug (which will be called from xldeviced)
and libxl_device_<type>_hotplug_add to libxl_device_<type>_add, this
will mean less modifications in xl code since it will call the same


> Ian.

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.