[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] Re: [Xen-devel] [PATCH 4 of 6] libxl: support suspend_cancel in domain_resume
On Tue, 2012-01-31 at 01:05 +0000, rshriram@xxxxxxxxx wrote: > # HG changeset patch > # User Shriram Rajagopalan <rshriram@xxxxxxxxx> > # Date 1327971527 28800 > # Node ID efe92d80c47487485056266a1404a8d2817b7f09 > # Parent cd3d43d88c0568142dd061e744c34479e1a440f4 > libxl: support suspend_cancel in domain_resume > > Add an extra parameter to libxl_domain_resume indicating > if the caller wishes to use the SUSPEND_CANCEL style > resume instead of the normal resume. > > Signed-off-by: Shriram Rajagopalan <rshriram@xxxxxxxxx> > > diff -r cd3d43d88c05 -r efe92d80c474 tools/libxl/libxl.c > --- a/tools/libxl/libxl.c Mon Jan 30 16:58:31 2012 -0800 > +++ b/tools/libxl/libxl.c Mon Jan 30 16:58:47 2012 -0800 > @@ -229,24 +229,29 @@ int libxl_domain_rename(libxl_ctx *ctx, > return rc; > } > > -int libxl_domain_resume(libxl_ctx *ctx, uint32_t domid) > +int libxl_domain_resume(libxl_ctx *ctx, uint32_t domid, int fast) > { > GC_INIT(ctx); > int rc = 0; > > - if (LIBXL__DOMAIN_IS_TYPE(gc, domid, HVM)) { > - LIBXL__LOG(ctx, LIBXL__LOG_DEBUG, "Called domain_resume on " > - "non-cooperative hvm domain %u", domid); > - rc = ERROR_NI; > - goto out; > - } > - if (xc_domain_resume(ctx->xch, domid, 0)) { > + if (xc_domain_resume(ctx->xch, domid, fast)) { > LIBXL__LOG_ERRNO(ctx, LIBXL__LOG_ERROR, > "xc_domain_resume failed for domain %u", > domid); > rc = ERROR_FAIL; > goto out; > } > + > + if (LIBXL__DOMAIN_IS_TYPE(gc, domid, HVM)) { > + rc = libxl__domain_resume_device_model(gc, domid); > + if (rc) { > + LIBXL__LOG(ctx, LIBXL__LOG_ERROR, > + "failed to resume device model for domain %u:%d", > + domid, rc); > + goto out; > + } > + } > + > if (!xs_resume_domain(ctx->xsh, domid)) { > LIBXL__LOG_ERRNO(ctx, LIBXL__LOG_ERROR, > "xs_resume_domain failed for domain %u", > diff -r cd3d43d88c05 -r efe92d80c474 tools/libxl/libxl.h > --- a/tools/libxl/libxl.h Mon Jan 30 16:58:31 2012 -0800 > +++ b/tools/libxl/libxl.h Mon Jan 30 16:58:47 2012 -0800 > @@ -268,7 +268,7 @@ int libxl_domain_create_restore(libxl_ct > void libxl_domain_config_dispose(libxl_domain_config *d_config); > int libxl_domain_suspend(libxl_ctx *ctx, libxl_domain_suspend_info *info, > uint32_t domid, int fd); > -int libxl_domain_resume(libxl_ctx *ctx, uint32_t domid); > +int libxl_domain_resume(libxl_ctx *ctx, uint32_t domid, int fast); Please can you add a few words about what fast means and when its use would be appropriate. I'm not sure fast is right word -- it happens that this mechanism is faster but isn't the real meaning "co-operative" or something along those lines? Would a better name be libxl_domain_suspend_cancel, sharing a common helper internally with libxl_domain_resume? Ian. > int libxl_domain_shutdown(libxl_ctx *ctx, uint32_t domid); > int libxl_domain_reboot(libxl_ctx *ctx, uint32_t domid); > int libxl_domain_destroy(libxl_ctx *ctx, uint32_t domid); > diff -r cd3d43d88c05 -r efe92d80c474 tools/libxl/xl_cmdimpl.c > --- a/tools/libxl/xl_cmdimpl.c Mon Jan 30 16:58:31 2012 -0800 > +++ b/tools/libxl/xl_cmdimpl.c Mon Jan 30 16:58:47 2012 -0800 > @@ -2751,7 +2751,7 @@ static void migrate_domain(const char *d > if (common_domname) { > libxl_domain_rename(ctx, domid, away_domname, common_domname); > } > - rc = libxl_domain_resume(ctx, domid); > + rc = libxl_domain_resume(ctx, domid, 1); > if (!rc) fprintf(stderr, "migration sender: Resumed OK.\n"); > > fprintf(stderr, "Migration failed due to problems at target.\n"); > @@ -2773,7 +2773,7 @@ static void migrate_domain(const char *d > close(send_fd); > migration_child_report(child, recv_fd); > fprintf(stderr, "Migration failed, resuming at sender.\n"); > - libxl_domain_resume(ctx, domid); > + libxl_domain_resume(ctx, domid, 1); > exit(-ERROR_FAIL); > > failed_badly: _______________________________________________ Xen-devel mailing list Xen-devel@xxxxxxxxxxxxxxxxxxx http://lists.xensource.com/xen-devel
|
Lists.xenproject.org is hosted with RackSpace, monitoring our |