[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] VGA passthough still not working


Yes, I did verify that IOMMU is enabled. I get this in my xm dmesg:
(XEN) I/O virtualisation enabled
(XEN) Intel VT-d Snoop Control supported.
(XEN) Intel VT-d DMA Passthrough not supported.
(XEN) Intel VT-d Queued Invalidation supported.
(XEN) Intel VT-d Interrupt Remapping not supported.

But I dont think I have this message (I am not near my system now, so I can not confirm)

(XEN) I/O virtualisation for PV guests enabled

I believe that many have managed to get VGA passthru working, but they generally dont post their stories. one only finds the problems they are encountering when searching about this. That is why it would be nice to put together a kind of manual in the wiki which would have all this info together in one location.

Thanks for the help



On Fri, Jan 20, 2012 at 9:32 PM, Pasi Kärkkäinen <pasik@xxxxxx> wrote:
On Fri, Jan 20, 2012 at 05:49:20PM +0100, Sandi Romih wrote:
>    Pasi,
>    I have that enabled in my BIOS, VT-d for the chipset and VT-x for the CPU.

Ok. And Xen enables IOMMU? Did you verify from Xen's dmesg ?


>    Have you managed to pass your gpu through to the domU?

No, I haven't tried that yet. I've been planning to, but I haven't had time for it yet.

There are many people who are using Xen VGA passthru with Intel, AMD/ATI and Nvidia graphics cards.
Currently it needs a lot of understanding and some custom patching, but you can make it work.

There are even businesses using Xen VGA passthru in production :)

-- Pasi

>    Sandi
>    On Jan 20, 2012 4:47 PM, "Pasi Kärkkäinen" <[1]pasik@xxxxxx> wrote:
>      On Fri, Jan 20, 2012 at 02:05:43PM +0100, Sandi Romih wrote:
>      >    Hello,
>      >    I have spent a lot of time trying to get gfx passthru working on my
>      system
>      >    without success.
>      >    I looked onto my hardware capabilities again to make sure that it
>      does
>      >    support VT-d and I am not too sure that it does fully.
>      >    My hardware is as follows:
>      >    - Supermicro X8DTH-6F motherboard (5520 chipset which supports
>      VT-d)
>      >    - single Xeon X5650 CPU (which is listed as supporting VT-x, no
>      mention of
>      >    VT-d at [1][2]ark.intel.com)
>      >    Now, according to the [2]VTdHowTo, the motherboard BIOS, chipset
>      AND CPU
>      >    need to support VT-d.
>      >    What confuses me is, why is the 55x0 chipset listed there if none
>      of the
>      >    CPU's supported, that I know of, dont have the VT-d feature option,
>      only
>      >    VT-x.
>      >
>      I've been using VT-d with Xen with Intel 5500 series chipset, and Xeon
>      5600 series CPU.
>      VT-d needs to be enabled in the BIOS.
>      -- Pasi
> References
>    Visible links
>    1. mailto:pasik@xxxxxx
>    2. http://ark.intel.com/

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.