[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] Re: [Xen-users] [Project Kronos] XAPI on Debian

On 10/11/2011 09:17 PM, msgbox450@xxxxxxxxx wrote:
It logs in with xencenter 6 and lists the domains ok, it shows the ram and cpu usage and the cpu/network graphics work etc.

Good so far...
Importing .xva such as the xenserver test vm doesnt work... just sits there "preparing to import VM" forever.

Can you provide a snippet of the logfile /var/log/xensource.log from the point that you start the import to the point where you give up waiting on it?
Creating a VM from a template seems to work on the surface but then when trying to start it I get: 11/10/2011 19:50:20 Error: Starting VM 'CentOS 6.0 (32-bit)' - Internal error: Unix.Unix_error(20, "access", "/usr/bin/eliloader")
I get the same error with a debian template too.

PV templates (those other than the 'Other install media' template) require the eliloader package. We just packaged this up a week ago, and it doesn't look like the xapi package depends upon it yet. I've filed a bug for this particular issue.

Try doing 'apt-get install eliloader', and make sure that your other packages are up-to-date as well.
Trying to create a fresh VM from any ISO I've tried (debian, centos, suse) it provisions the VM but then when starting it just says "Starting" forever and never actually starts or gives an error.

Were these PV templates, or 'Other install media' templates (see above). Log snippets from the time after you started the VM would help diagnose this.
I've just reinstalled the debian+xapi from scratch but still no difference.

Also, it appears that once created, I have no option to delete the VMs from the xencenter menu.

Does any of this work when you use the CLI? Is anything different?


xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.