[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] Re: [Xen-users] [Project Kronos] XAPI on Debian

It logs in with xencenter 6 and lists the domains ok, it shows the ram and cpu usage and the cpu/network graphics work etc.

Importing .xva such as the xenserver test vm doesnt work... just sits there "preparing to import VM" forever. 

Creating a VM from a template seems to work on the surface but then when trying to start it I get:
11/10/2011 19:50:20 Error: Starting VM 'CentOS 6.0 (32-bit)' - Internal error: Unix.Unix_error(20, "access", "/usr/bin/eliloader")
I get the same error with a debian template too.

Trying to create a fresh VM from any ISO I've tried (debian, centos, suse) it provisions the VM but then when starting it just says "Starting" forever and never actually starts or gives an error.

I've just reinstalled the debian+xapi from scratch but still no difference.

Also, it appears that once created, I have no option to delete the VMs from the xencenter menu.

On Tue, Oct 11, 2011 at 6:24 PM, Mike McClurg <mike.mcclurg@xxxxxxxxxx> wrote:
Hi! First of all, thanks for testing Kronos for us!

On 11/10/11 13:31, msgbox450@xxxxxxxxx wrote:
Ah, I found the dom0 was using the RAM, so a "xm mem-set 0 512" has reduced the RAM it uses and I've managed to boot an iso.

You might also have luck with passing the option 'dom0_mem=512M' to Xen from grub.

The XAPI still doesnt seem to be working right with XenCenter though... the console hangs, VMs can't be imported etc. I wonder what is wrong :(

Could you be a little more explicit with these bug reports? For instance:

What version of xapi are you using? The output of 'apt-cache show xapi | grep Version' would be helpful.

What do you mean by "console hang"? Does the console work, and then freeze, or does the console not work at all?

What type of VMs can't be imported? As in, what is the file extension of the VMs that can't be imported?

Do these things work when you use OpenXenManager? Does XenCenter give you any particular error messages? Can you find any error messages in the logs that might be relevant?

Thanks for the help,


On Tue, Oct 11, 2011 at 1:00 PM, msgbox450@xxxxxxxxx <msgbox450@xxxxxxxxx> wrote:
I've now got XenCenter to connect to XAPI on Debian, I had to run "/etc/init.d/xapissl start" which has created the config files and enabled XenCenter to connect via SSL.

The problem I have now is that XenCenter 6 doesn't seem to actually do anything... it connects, synchronises, everything appears to work on the surface. However, it detects only 92mb of RAM is free on the host (which is a big lie) and therefore can't create any VMs, and trying to import an .xva it just sits there "preparing" forever.

I've tried creating /etc/xensource/xapi_version_override with a line containing 5.6.199 and then done "service xapi restart", but this doesn't seem to make any difference :(

xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.