[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Network connections stalling - Debian Linux domU's

  • To: xen-users@xxxxxxxxxxxxx
  • From: "Størner.Henrik Juul HSO" <henrik@xxxxxxx>
  • Date: Tue, 22 Jul 2014 18:24:10 +0200
  • Delivery-date: Tue, 22 Jul 2014 17:43:08 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>


On 20-07-2014 19:43, Steve Dawson wrote:
On 07/20/2014 12:35 PM, Henrik Størner wrote:
service, the network connection quickly stalls. A "netstat" on the domU
shows a very large Send-Q (i.e. data sent, but not acknowledged by the
remote end of the connection) - usually around 25000, it ought to be
quite small. A tcpdump also shows very large intervals between packets,
10-30 seconds is not uncommon.

After reading a bunch of docs, blogs etc, I tried these things:
   - Dom0 memory fixed at 2 GB, ballooning disabled
   - CPU 0+1 dedicated to dom0 (pinned), the domU's configured to
     NOT use CPU 0+1
   - CPU 4.5 dedicated to the mail server domU
   - txqueuelen on the VIF changed to 1024

Neither of these appear to make any difference whatsoever
It could be hyper threading, either disable it, or manually pin your domU's 
cpus in pairs. I had a similar issue running a bunch of citrix xenapp  (2008 
windows terminal) servers with hyper threading enabled, when the loads got to 
about 30% the load averages would skyrocket suddenly, pinning the cpus fixed 
the problem.

Following this, I have disabled hyperthreading - no effect at all.

I can also reproduce it by simply transferring a large file with sftp - so is isn't just IMAP/Thunderbird that triggers it.

Dom0 is pinned to PCPU 0, the domU's are free to use any of the remaining CPU's. I have tried allocating a full CPU to the mail domU I am testing with, this did not have any effect either. Auto-ballooning is also disabled so dom0 doesn't run out of memory (it has 2 GB).

One observation: It seems to happen only with IPv4. If I connect to the server using IPv6, everything runs fine - mail, sftp etc is OK. Are there any IP- or TCP-settings that could cause this?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.