[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] solved: DomU P2V, no drive found

  • To: XenUsers <xen-users@xxxxxxxxxxxxx>
  • From: Flako <subforos@xxxxxxxxx>
  • Date: Fri, 2 Aug 2013 09:48:16 -0300
  • Delivery-date: Fri, 02 Aug 2013 12:50:49 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

2013/8/1 Alexandre Kouznetsov <alk@xxxxxxxxxx>:
> Hello.
> El 01/08/13 15:31, Flako escribió:
>> Alexandre
>>      Should not put the puck as if sdxx or hdxx, but it sure is the 2nd
>> partition (this is how you create the partitions and is as seen from
>> qemu-nbd)
>>      Believing the links (/dev/disk/by-uuid/) and mknod devices
>> accessing the disk via qemu-nbd (probe with hda2,hdb2,sda2,sdb2). But
>> then when you start the domU in the bash-like console do not appear.
>> :(
>>      Then I did the same from the bash-like domU console and try to
>> mount the disk, the mount command shows the error 'is not a valid
>> block device'
>>         $ mount  -t reiserfs  /dev/sdb2 /aa
>>         mount: /dev/sdb2 is not a valid block device
> If you can get into that back-like domU console again, try this:
> ls -al /dev/disk/by-uuid
> ls -al /dev/disk/by-uuid/fb5c6b0b-3688-43cd-8b20-d8fa3a0ba993
>> xen_vbd locate the module in the domU (SLES11SP1) and the module does not
>> exist.
>> Looking in there dom0 (SLES11SP2) module, this in /
>> lib/modules/3.0.13-0.27-default/updates/blkfront/xen-vbd.ko (Package
>> xen-kmp-default-4.1.2_14_3.0.13_0.27-0.5.5.rpm)
> I did not understand if the file
> /lib/modules/3.0.13-0.27-default/updates/blkfront/xen-vbd.ko
> is present in your system or not. If not, reinstall package
> xen-kmp-default-4.1.2_14_3.0.13_0.27-0.5.5.rpm. Verify if the kernel you are
> running is indeed "3.0.13-0.27-default".
> It's also possible, that the module is present in the system but not in the
> initrd (check that). In that case, rebuid your initrd.
> This reference should tell you how to add modules and rebuild initrd.
> ftp://ftp-uxsup.csx.cam.ac.uk/pub/doc/suse/suse9.2/suselinux-adminguide_en/ch10.html
>>       I have already run out of ideas ..
>>       Any idea where to look and read?
> Did you tried using ioemu flag?
> --
> Alexandre Kouznetsov

     With your guidance to start correctamete achieved.
     Now-hvm domU starts :)
    Thank you very much.

     What was missing was to rebuild the initrd with the command:

               mkinitrd -vk /boot/vmlinux- -i
/boot/initrd- -M
/boot/System.map- -d /dev/sda2

     edit  /boot/grub/menu.lst to use the new initrd and
root=/dev/hda2 . with this worked

     Though not clear to me why it was necessary to create it again,
in the INITRD_MODULES was defined xen-vbd module (INITRD_MODULES =
"xen-vbd piix ata_piix ata_generic processor fan ide_pci_generic
xen_vbd reiserfs edd")
      Either because you need to use the parameter '-d / dev/sda2'
(with /dev/hda2 does not work), being that just started using Linux

     Answering your question, the option ioemu, if I'm using it since
I inidicaste, but makes no boote use the domU.
     By xen-vbd.ko module was in the domU and dom0 (I to get it confused me)

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.