[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen kernel: File not found issue

  • To: xen-users@xxxxxxxxxxxxx
  • From: Alexandre Kouznetsov <alk@xxxxxxxxxx>
  • Date: Mon, 24 Jun 2013 10:34:27 -0500
  • Delivery-date: Mon, 24 Jun 2013 15:35:37 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

El 22/06/13 13:56, varun bhatnagar escribió:
I have installed Xen-4.1.4 and I tried booting it with xen kernel but I
am getting a message saying Error No 15 : File not found.
What Linux distribution are you using?

I tried editing the grub entry and noticed that there are 3 entries:
1) kernel /boot/xen.gz vga= mode-0x345
2) module /boot/vmlinuz-3.0.13-0.27-xen.......
3) module /boot/initrd-3.0.13-0.27-xen

And in /boot i listed down the files, only xen.gz is there. Rest of the
2 files are not there (pasted the screenshot below).
Can't see your screenshot. Maybe you could paste the output of "ls -al /boot" in text form?

Even at one site it was given to remove /boot from the path but that
also din't work.
Yes, that needs to be done if your "/boot" resides on a different device that the rest of your "/". In the case the kernel and initrd images are located in the root of that partition.

How shall I solve this one?
It depends on what distirbutin you use. Apparently, your system misses it's kernel, or incorrect kernel is referenced in grub.conf. I assume, if a different Grub boot option is chosen, the system boot just fine. Additionally to "ls -al /boot" output, could you paste 2 fragments from you grub.conf? The one that attempts to boot into Xen and the one that boots successfully without Xen.


Alexandre Kouznetsov

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.